Memory leak when rearranging bookmark on the bookmarks toolbar

RESOLVED DUPLICATE of bug 323405

Status

()

RESOLVED DUPLICATE of bug 323405
13 years ago
13 years ago

People

(Reporter: mozbugs, Unassigned)

Tracking

({memory-leak})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060120 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060120 Firefox/1.6a1

See steps to reproduce

Reproducible: Always

Steps to Reproduce:
1.Open browser to homepage about:blank
2.Drag a bookmark from the bookmarks toolbar to a new position on the bookmarks toolbar
3.Run leak-gauge

Actual Results:  
Leaked outer window 8cf8b70 at address 8cf8b70.
Leaked inner window 8efee38 (outer 8cf8b70) at address 8efee38.
 ... with URI "chrome://browser/content/browser.xul".
Summary:
Leaked 2 out of 6 DOM Windows
Leaked 0 out of 26 documents
Leaked 0 out of 3 docshells



Tested a new profile & no extensions
This may be a duplicate of bug #323405 which is currently Windows only.

Updated

13 years ago
Keywords: mlk
Summary: Memory leak when rearranging bookmark on the bookmarks toolbar - mlk → Memory leak when rearranging bookmark on the bookmarks toolbar

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 323405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
I believe that this problem is actually caused by placing increasing numbers of bookmarked URL's in the bookmarks toolbar folder.  This has been true of all previous versions as I have experienced this problem.  It is easy to duplicate the problem.  After a certain number of links, dropping URL links into the bookmarks toolbar folder causes a memory leak and the CPU utilization jumps to somewhere over 95%.   Removing the bookmarks from this folder causes this behavior to disappear.   Currently I am using 1.5.0.3 and this behavior still exists.  Basically, the bookmarks toolbar folder must be small or memory leaks/CPU utilization problems will appear.
You need to log in before you can comment on or make changes to this bug.