Automatic Mail Check Not Working - POP

VERIFIED FIXED in M17

Status

P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: jay, Assigned: gayatrib)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] part of feature exception)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14)
BuildID:    31815

Mail check frequency set to arbitrary time period. Appears to be checking for
new mail in the status bar but new mail not downloaded or even appear to have
any for that matter.

Reproducible: Always
Steps to Reproduce:
1.Set prefs to check mail every x minutes
2.Set prefs to download new mail
3.Send mail to yourself to verify feature


Actual Results:  New mail does not arrive

Expected Results:  Expect new mail to download or at least show up.
(Reporter)

Comment 1

19 years ago
Manual mail checks work ok as expected

Comment 2

19 years ago
hey scott, does this sound like you? The fact that the protocol get new mail
works makes me think it may be related to firing the biff notification instead
of the actual protocol work. but i could be wrong.
Assignee: mscott → putterman

Comment 3

19 years ago
I don't know. Does the M15 build work any better for you?

Comment 4

19 years ago
Does this still happen? Is this Imap or pop?  Imap should work, but pop will not
download headers currently regardless of whether or not the pref is set.  If
it's the latter, then jefft already has a bug on this.
(Reporter)

Comment 5

19 years ago
No auto-check on a POP account

Comment 6

19 years ago
I consider you lucky that your manual mail check works OK;
I can only get new mail by changing to the drafts folder and back to the Inbox.

Comment 7

19 years ago
reassigning to gayatrib.
Blocks: 36011

Comment 8

19 years ago
Jay, I didn't understand your comment.  Is this set up on POP?  If so, do you
have it set to automatically download headers?
Assignee: putterman → gayatrib
(Reporter)

Comment 9

19 years ago
Set for POP, 5 minute interval and download new messages. Auto-check never 
occurs. Also evident in today's build 41605. 

Updated

19 years ago
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Networking - General → Mail Window Front End
Ever confirmed: true
QA Contact: lchiang → fenella
Summary: Automatic Mail Check Not Working → Automatic Mail Check Not Working - POP
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 10

19 years ago
Target M17.
Target Milestone: --- → M17
(Reporter)

Comment 11

19 years ago
*** Bug 40035 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
I tried pop the other day and it worked fine for me (it even downloaded my 
headers when I didn't want it to.  Apparently we've taken this pref out of the 
UI).

One thing that I didn't mention before is that you have to be logged into the 
account in order for biff to work.

Comment 13

19 years ago
moving to M18 and nominating for beta3.  We need to investigate this.  All types 
of biff are working fine for me.
Target Milestone: M17 → M18

Comment 14

19 years ago
oops. I just realized that was silly. We have a feature exception for biff.  
Putting nsbeta2+ on this and moving back to M17.
Keywords: nsbeta2
Whiteboard: [nsbeta2+] part of feature exception
Target Milestone: M18 → M17

Comment 15

19 years ago
*** Bug 35142 has been marked as a duplicate of this bug. ***

Comment 16

19 years ago
As of M16, here's what I've noticed.  You have to hit get messages once after
opening the Mail window, and then auto checks start happening.  Still don't get
a sound played, tho.

Comment 17

19 years ago
playing a sound is another bug that we don't plan on implementing any time soon.
(Reporter)

Comment 18

19 years ago
Kick-Starting by GetMessage first works here as well ...
(Assignee)

Comment 19

19 years ago
Fix checked in. 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 20

19 years ago
Win32 and Mac (2000-06-26-09 M17)
Automatic Mail check is working on win_nt 4.0 in POP. When new message arrives,
Biff shows up in the Status bar, Account  and Folder level as well as message
appears in the thread pane.

Linux (2000-06-26-08 M17) 
Biff  show ups in the Status bar, Account level. But it does not show up in the
folder level and thread pane. I need to click on the Get Msg so that it appears
in the Thread pane.

Since automatic check is working. I am going to verify this bug and open a new
one for linux only.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 21

19 years ago
Win98SE build 62608 

Still does not work here. Mail set to check every 5 minutes. Sent mail from 
another account. Did not auto-check/receive message until manually checked. 
After manually checking I sent another email from a different account using 
another mail app and still not auto-checked/received until manually checked.

Created another profile and still no auto-check/receive under same conditions as 
above.

I'll be happy to try any suggestions.

Comment 22

19 years ago
Wow, I'm really not seeing this on any of my machines.  I just tried pop and it 
worked fine on NT.  Imap works for me as well.  Earlier today I tried Linux and 
that worked for me also.  We need to find out what the difference is between 
what gayatrib and I tested and what everyone else is testing.

Comment 23

19 years ago
Fenella, can you work with Jay to figure this out?
(Assignee)

Comment 24

19 years ago
I just verified this on the release builds for Windows NT/Linux/Mac. I tried 
Imap,Pop. Biff is working just as expected. There should either be something 
different about the way I am testing, or it could be that I am missing 
something. I am waiting to find some in QA, so that I can sit down with them and 
see how it works. 
(Assignee)

Comment 25

19 years ago
I thought I'd mention the sequence of steps that need to be done before biff can 
take effect. Please do the following:

How to enable: 
After opening the mail window, go to: 
Edit 
Mail/News Account Settings 
Server (mail server) 
Check the option that says "Check for new mail every xx min" 
And enter your favorite time interval to check mail 
Click on OK. 

Unfortunately, you would have to RESTART the application for this setting to 
take effect. It is a bug that needs to be fixed... Bug 24594. 

Once you restart the app, and open the mail window, you should remember to LOGIN 
into your accounts (impa/Pop).

You should now see biff working.

Please try again with the above sequence of steps, and see if it works.
(Reporter)

Comment 26

19 years ago
After jumping through a few hoops I finally got it working. However, I have to 
GET MAIL *first* to get the auto-check to start working. And once Mozilla is 
closed and restarted I have to login again to jump-start the auto-check.

Comment 27

19 years ago
biff can't happen unless you are logged in. We have another bug about prompting 
for passwords when mail is started up but even then, if you don't log in we 
can't perform biff.
(Assignee)

Comment 28

19 years ago
I also thought I'd add that on Imap accounts I think you are automatically asked 
to enter your password. So you know you have logged in.

Whereas on pop accounts, to login, you have to explicitly do a GetMsg. Only then 
you will be prompted with a password dialog, after entering which you are logged 
in.

From then on biff should work.
(Reporter)

Comment 29

19 years ago
So why not auto-login when Mozilla loads or when mail/news is started just as in 
the 4.x series?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.