All users were logged out of Bugzilla on October 13th, 2018

camino (and FireFox 1.5) hang (unresponsive in force quit dialog) trying to load above page

RESOLVED DUPLICATE of bug 325084

Status

--
critical
RESOLVED DUPLICATE of bug 325084
13 years ago
8 years ago

People

(Reporter: chris.m.franklin, Assigned: smichaud)

Tracking

1.8 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051229 Camino/1.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051229 Camino/1.0b2

enter above URL into Camino or FireFox 1.5. window starts to load and puts message in scroll area about loading data from ishares.  camino becomes unresponsive. there is a Java applet on the page to draw a chart.  this works fine in Safari and  IE on Windows XP.  Camino hangs and needs to be killed in Force Quit in Finder.

Reproducible: Always

Steps to Reproduce:
1. enter url
2. expect page to load with chart
3. observe camino is now unresponsive

Actual Results:  
camino unresponsive

Expected Results:  
show page like Safari or IE on Windows XP

Comment 1

13 years ago
Doesn't hang Camino for me, but doesn't load the graph.

Either way, since this occurs on FF as well, should this be Core rather than Camino?

Comment 2

13 years ago
The affected URL does not appear to be publicly accessible. Reporter, can you post a publicly accessible URL that has the same problem?

cl

Comment 3

13 years ago
The above URL redirects me to this page:

http://www.ishares.com/splash.jhtml

which displays fine, by the way. Just FYI.

cl
(Reporter)

Comment 4

13 years ago
This may be Intel dependent (I'm running on a new Dual Core iMac).  A buddy tried to repro on G5 with no luck.  the URL should be public.  Here are alternative steps to get there:
1. enter www.ishares.com
2. Quick Finder menus should be on the top left of page. Choose International->Americas->MSCI Canada Fund (EWC)
3. In the middle of the page, find and click on link Premium/Discount Chart (it's immediately under the first Table Title NAV/Price as of mm/dd/yyyy.

Comment 5

13 years ago
Chris, it sounds like you're running the official PowerPC version under Rosetta?

Comment 6

13 years ago
(In reply to comment #4)

> 1. enter www.ishares.com
> 2. Quick Finder menus should be on the top left of page. Choose
> International->Americas->MSCI Canada Fund (EWC)
> 3. In the middle of the page, find and click on link Premium/Discount Chart
> (it's immediately under the first Table Title NAV/Price as of mm/dd/yyyy.

Using these steps, I get the behaviour described in comment #1. Likewise with Fx 1.5 official release. I get a chart in Safari.

Why these people think they need to use Java to display a simple graphic is beyond me, but my guess is we've got a JEP issue here.

cl
(Reporter)

Comment 8

13 years ago
not a problem in camino universal 1.0rc1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 9

13 years ago
Not because anything's been fixed, but because you've taken Rosetta out of the equation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 10

13 years ago
On the second thought, I'm reopening and giving it to Steven.  We should try to not crash when loading Java under Rosetta, we should just fail.  Steven, if you don't want this bug, I'll take it (but I'll need to give the patch to you anyway, so...)

See also bug 323657 comment 23.
Assignee: mikepinkerton → smichaud

Updated

13 years ago
Component: Plug-ins → Java: OJI
Product: Camino → Core
Version: unspecified → 1.8 Branch
(Assignee)

Comment 11

13 years ago
I can't do anything about this bug until I get my own Apple Intel box.  I'm
planning to get a MacBook Pro, which I hope I'll be able to lay hands on by
late February to early March (depending on when Apple starts shipping them).
Until then, Mark, this bug is yours by default :-)

Comment 12

13 years ago
Oh, guess what?  I already created a bug for that issue.

*** This bug has been marked as a duplicate of 325084 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.