javascript windows open with wrong size, not resizable

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: mynnia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8) Gecko/20051111 Firefox/1.5

Javascript-generated windows open with only three quarters of the width the window should have and those windows are not resizable.
The example website was tested without problems with 1.0.7 Debian GNU/Linux.
Same problem occurs on a variety of other sites, like kingdomofloathing.com (account required). The latter's windows normally are definitely resizable normally.

Reproducible: Always

Steps to Reproduce:
1. Open site.
2. Click on one of the pictures
3. Let the window open.

Actual Results:  
The picture is cut from the left side at quite exactly three quarters, because the window cuts off there.

Expected Results:  
The picture should show all you can see on the thumbnail.

Extensions, all updated weekly:
Fasterfox
Adblock
All-in-one-Gestures
Down-them-all
Colorzilla
TinyURL Creator

Theme: default

Comment 1

12 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
WFM. You could make it resizable (but it's not necessary in this case) by typing about:config in your urlbar and double-clicking on dom.disable_window_open_feature.resizable

Comment 3

12 years ago
wfm

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060123 Firefox/1.6a1
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111
> Firefox/1.5
> WFM. You could make it resizable (but it's not necessary in this case) by
> typing about:config in your urlbar and double-clicking on
> dom.disable_window_open_feature.resizable
> 

I didn't even have such an entry and added it, just to see if enabling or disabling would make a difference.
It doesn't change a thing, but thank you.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> (In reply to comment #2)
> > Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111
> > Firefox/1.5
> > WFM. You could make it resizable (but it's not necessary in this case) by
> > typing about:config in your urlbar and double-clicking on
> > dom.disable_window_open_feature.resizable
> > 
> 
> I didn't even have such an entry and added it, just to see if enabling or
> disabling would make a difference.
> It doesn't change a thing, but thank you.
> 

Sorry for the self-reply, but is it normal that I cannot swith between true and false for general.autoScroll? It's on false now.
As everything works here OK on the site you mentioned and dom.disable_window_open_feature.resizable to true really makes it resizable, I suggest you to cleanup your profile (or make a new one).
Cleanup: In your profile delete everything except for the most important files like bookmarks.html, key3.db, signons.txt, cookies.txt.
Location of the profile folder: http://kb.mozillazine.org/Profile_Folder#Firefox
 
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

12 years ago
OK, it was a problem with Fasterfox and preredendering of the window before the content is fully loaded...
Not a bug in Firefox = invalid.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.