Can not print or print preview an e-mail

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: H Beitman, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060124 SeaMonkey/1.5a

Since about 1/16/06 all Seamonkey nightly builds I have tried fail to print e-mails.  I have a build from 1/3 and it works fine, but all downloaded since do nothing when "Print" or "Print Preview" is requested.  Print does work for web pages.

Reproducible: Always

Steps to Reproduce:
1. Install current nightly build
2. Bring up any e-mail (text, html)
3. Try to Print or Print Preview

Actual Results:  
Nothing happens.  It is as if the buttons do not exist.  Printing works on web pages printed in the browser mode.

Expected Results:  
Should print or print preview.

I can go back to the 1/3/06 build, or any older build, and printing works fine.  Printing works fine in all other programs on the computer.

I have tried three nightly builds over the past few weeks and all since 1/3 have this problem: 1/16, 1/18, 1/24.

Comment 1

12 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060122 SeaMonkey/1.5a
Tested on Print Preview only, plain text only, with and without headers, POP3 and IMAP, but I've got a local directory for IMAP.
I first tested using the context menu, then used Preferences/Navigator to create a Print button, and used Print Preview from this button, same result.
File menu Print Preview also working.
monochrome Printer Canon BJ330
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
 
I believe you are running Win98 from the data in your comments.  Perhaps that is the difference and why it works for you?  Or maybe your printer being different might be the issue.

I have WinXP SP2, with an HP Laserjet 6L printer.  With builds since about 1/16 no print function (print preview or print) from any menu source or view work (e-mail only).  If I reload the build from 1/3 or earlier it all works fine.  So clearly the problem is in the later builds for Windows under XP.

I am surprised there haven't been other complaints about this since it would be a big problem for anyone who needs to print an e-mail.  Thanks for looking into the issue. 

Comment 3

12 years ago
Do you see any errors in the JS console if you are trying to print?
Version: unspecified → Trunk
(Reporter)

Comment 4

12 years ago
I downloaded a series of builds from 1/4 to 1/116 to try and narrow down when the print problem may have started.  Windows build from 1/4 works fine.  Windows build from 1/5 has the problem, as do all subsequent builds.

This problem shows up in a second WinXP computer we have, so it is not isolated to my machine.

I looked at changes made around 1/4 and found bug #311028 which refers to a print preview fix - maybe that change caused this issue?

H. Beitman

Comment 5

12 years ago
confirming based on reporter's information
He sent a private mail:
> I did a little research on the print problem with the last few builds.
> > I think when the "scam button" message was changes from "Not a scam" to
> > "Allow remote content" and whatever other changes that entailed, it
> > caused the print problem.  The timing seems to be the same and both
> > things only affect e-mail.

Timeframe for regression according to comment 4:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-01-04+00%3A00&maxdate=2005-01-05+23%3A59&cvsroot=%2Fcvsroot

Bug 311028 Print Preview window is partly overlayed by background and is missing scrollbars

Attachment #207272 [details] [diff] 
got superreview       2006-01-04 11:55:36 PST Bug 311028 Comment 28
got marked checked in 2006-01-04 15:04:40 PST Bug 311028 Comment 29

Checkin isn't seen in bonsai
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 6

12 years ago
(In reply to comment #3)
> Do you see any errors in the JS console if you are trying to print?
> 
No, there is no error indicated.  Even plain text messages won't print or preview.

All web pages print just fine.  It is just e-mails that won't print.
(Reporter)

Comment 7

12 years ago
I have experimented with late builds using files from the working versions of 1/4/06 and before.  Moving the entire Chrome directory from a 1/4/06 build to a nightly from 1/26/06 fixes the print preview and print problem.  Other problems might arise that I have not found yet, but the printing issues go away.

If I move only the "comm.jar" file from the 1/4 build Chrome directory to the 1/26 build, the print feature returns in e-mail, but no print preview.

Conclusion: the Chrome directory contains the problem and the "comm.jar" file is part of the problem.  Does anyone know what changed in the "comm.jar" file and other Chrome components between 1/4/06 and 1/5/06?
(Reporter)

Comment 8

12 years ago
I uploaded the most recent build on 2-5-06 and this one works, it prints e-mails properly.  I had been copying the "chrome" directory from an earlier build (prior to 1-5-06) to get builds to work, but there were other problems with that approach - some menus did not work, etc.  But the last build does work.  I will check the next couple of builds and if they work, then the problem may be solved.

H. Beitman

Updated

12 years ago
Blocks: 326480
(Reporter)

Comment 9

12 years ago
I downloaded the nightly from 2/8 and installed it.  As with the build from 2/5, the e-mail print functions seem to work fine.  This is true on a second almost identical machine with an HP Laserjet printer as well.  I also tried various builds on a Windows XP machine with an HP inkjet printer and they all worked, so whatever the problem was, it seems to affect only Laserjet printers.

At any rate, based on the builds from 2/5 and 2/8, the problem with e-mail printing seems to have gone away.  I don't know if something specific was done to fix this or it is just the byproduct of some other changes.  I will continue to monitor builds, but I think the issue is resolved.

H. Beitman
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 10

12 years ago
Thanks for resolving the bug.
If you don't know which bug was fixed to fix this one, the resolution is WorksForMe. 'Fixed' is only for bugs where you know which patch checked in has fixed it. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

12 years ago
resolving WFM according to reporter's comment #9
feel free to reopen the bug ig the issue is seen again.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.