Can't type as it just beeps at me.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: albailey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Every once in while it seems that Firefox locks up and refusses to type it beeps my error sound for my mac. It happens over time. If you quit Firefox the bug goes away.I am not sure that I can dupicate the bug. It happens over varible times, and  not every time. You cannot type in the url bar or any where on the page. This bug does not occur at any one web page, and orcurs periodically.

Reproducible: Sometimes
More focus-related shenanigans?

Comment 2

12 years ago
I have run into this issue periodically too while using multiple instances of the broswer with multiple tabs open..

If I switch between one Firefox window and another one where there are several tabs open in each one, I will sometimes not be able to enter text in electronic form fields and the URL path.. I have to close the broswer instance and open a new one to resolve the issue..

Mac OSX 10.3.9
Firefox 1.5.0.1

Comment 3

12 years ago
Confirming based on comments.
Status: UNCONFIRMED → NEW
Component: Page Info → General
Ever confirmed: true
Flags: blocking-firefox2?

Comment 4

12 years ago
*** Bug 314022 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
*** Bug 309199 has been marked as a duplicate of this bug. ***
Without steps to reproduce, please don't bother nominating bugs.
Flags: blocking-firefox2?
QA Contact: page.info → general

Comment 7

12 years ago
I can confirm this bug as well.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1

It often happens to me when I do the following:

Either:

1. Open Firefox, do some browsing, close the browser window but NOT close Firefox itself. After awhile using other applications, click on Firefox in the dock to open up a new window. Often I cannot type in the URL bar, search fields, or anything. Quitting Firefox and restarting it will fix the problem temporarily.

2. Sometimes when Firefox is open and I minimize Firefox, do some work in other apps, then maximize Firefox, the same symptoms occur (not being able to type in the URL bar or search fields).

It has happened with the latest Bon Echo builds and with the first Firefox 2.0b1 builds.

Comment 8

12 years ago
Comment 7 part 2 sounds a lot like bug 294476 and should be fixed in 1.5.0.2 and later.  This sort of bug is notorious for being caused by third-party tools that inject themselves into your system and apps, such as APE.  If anyone experiences a bug like this one and is using any such software, try disabling it to see if you're still able to reproduce the bug.

Comment 9

12 years ago
Your right, that does sound like Bug 294476. However my OS X installation isn't modified at all and I don't have any third party apps that interact with Firefox (at least, as far as I am aware of). I don't even know what APE is.

I also have no extensions installed.
(Reporter)

Comment 10

12 years ago
This bug was fixed with recent releases of firefox, as far as I know. I did not have Ape installed.
Status: NEW → ASSIGNED
OS: Mac OS X 10.2 → Mac OS X 10.3

Comment 11

8 years ago
WFM per reporter
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.