<P ALIGN=[LEFT,RIGHT,CENTER]> lowers displayed text one line

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: Alex, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 1.0.2914)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0

<HTML><HEAD>
<STYLE TYPE="text/css">
<!--
DIV {position:absolute}
-->
</STYLE>
</HEAD>
<BODY>
<DIV STYLE="left:29;top:107;width:140;font:normal normal 10pt 'Arial';color:#000000">No alignment at all</DIV>
<DIV STYLE="left:170;top:107;width:140;font:normal normal 10pt 'Arial';color:#000000"><P ALIGN=CENTER>CENTER alignment</DIV>
<DIV STYLE="left:370;top:107;width:140;font:normal normal 10pt 'Arial';color:#000000"><P ALIGN=LEFT>LEFT alignment</DIV>
<DIV STYLE="left:570;top:107;width:140;font:normal normal 10pt 'Arial';color:#000000"><P ALIGN=RIGHT>RIGHT alignment</DIV>
</BODY></HTML>
renders as 
No alignment at all
                     CENTER alignment  LEFT alignment       RIGHT alignment


Reproducible: Always

Steps to Reproduce:
1.Paste HTML from 'details' to any .html file
2.Open it with FireFox and IE
3.Notice difference

Actual Results:  
I have to workaround the problem deleting justifying from my NEVRONA's RAVE report

Expected Results:  
FireFox should not change the vertical position of aligned caption
and
my site users will enjoy FireFox 

I hope that half of bugs found by 'align' query in your bugzilla corresponds
to the same problem

Updated

12 years ago
Keywords: testcase
Created attachment 209573 [details]
testcase with all parts the same

This is nothing to do with the align attribute, as this testcase shows just having a paragraph inside the DIV causes the text to be lowered. This is because by default paragraphs have a top margin on them.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 3

12 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.