Bug list says there are 49 bugs but only displays one

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Karsten Silz, Unassigned)

Tracking

Details

Attachments

(5 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I displayed a saved search which should display all 49 bugs but only showed on.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Display saved search.

Actual Results:  
One bug in the list.

Expected Results:  
49 bugs in the list.
(Reporter)

Comment 1

12 years ago
Created attachment 209656 [details]
Only one bug is shown instead of 49 ones.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.20

Comment 2

12 years ago
We cannot help if you don't tell us the kind of query you ran. And you say you cannot reproduce?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> We cannot help if you don't tell us the kind of query you ran. And you say you
> cannot reproduce?
> 

The query is: all new / assigned / reopened bugs in one Bugzilla product, saved as a search in my footer and invoked from there.  I tried to reproduce it by clicking around and then hitting that specific query. So for, I got just one bug once more - haven't found a pattern here, though.

Comment 4

12 years ago
If you have no testcase to reproduce the problem, this bug will probably ends as WFM.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> If you have no testcase to reproduce the problem, this bug will probably ends
> as WFM.

That's life - then I'll just have to cope with the bug whenever it occurs.

I have seen this numerous times on bmo. Usually it says it found X bugs but doesn't so anything in the list. Looks like you are also using Firefox, I wonder if this is a browser rendering bug. I just got this problem and looked at View Source that had the lines there but they were never shown. Could also be something strange in the generated HTML output too.

Refresh usually end up fixing this. Today I keep getting hit by this all the time on bmo. Could be a issue with DB load or something like that too..
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Created attachment 215049 [details]
Truncated bug list
(Reporter)

Comment 8

12 years ago
Yes, I also use Firefox.  I've seen it happening a number of times recently, showing just one or a few records while the search results claim a lot of results.  Our Bugzilla runs on Suse Linux 9.x.

Comment 9

12 years ago
(In reply to comment #6)
> ... looked at View Source that had the lines there but they were never shown.

if you save the source to disk and reload it from disk, does it still not display all the rows?

I've also seen this a few times.
I've seen this, too. Maybe it's a browser issue, or something about server push? I'm using FF 1.5.0.1.

When the bug occurs, the number of bugs shown varies for me, but it's usually a lowish number (read: something below 10).
(Reporter)

Comment 11

12 years ago
I also run Firefox 1.5.0.1.  But if the page HTML source doesn't include the bug list then this doesn't seem to be a browser rendering bug since Firefox can't render what isn't there.

Comment 12

12 years ago
Created attachment 216764 [details]
in this screen shot no bugs listed

(In reply to comment #11)
> I also run Firefox 1.5.0.1.  But if the page HTML source doesn't include the
> bug list then this doesn't seem to be a browser rendering bug since Firefox
> can't render what isn't there.

I suspect this will get closed as a browser issue. In my case the problem is with the browser because the full source is there - I saved the source, examined it, and opened the local file in FF just fine. Another possibility, IIRC, partitial table display can also happen if certain characters are in the table (I no longer remember the bug#)

If you find that the full HTML source isn't there then please post the source as an attachment.

In the screen shot attached, I opened a bookmarked group of addresses (below) in FF 1.5 with middle click. I've seen lots of truncations before but I can't recall if they ever happened other than with this bookmarks group.
  https://bugzilla.mozilla.org/buglist.cgi?product=Core&product=Mozilla+Application+Suite&chfieldfrom=0d&chfieldto=Now&chfield=%5BBug+creation%5D
https://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&changedin=1&chfield=%5BBug+creation%5D&chfieldto=Now
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyAll&branch=HEAD&branchtype=match&sortby=Date&date=day&cvsroot=%2Fcvsroot
http://mozillanews.org/bonsai/
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/
https://bugzilla.mozilla.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_severity=blocker&keywords=smoketest&cmdtype=doit&order=Reuse+same+sort+as+last+time

Comment 13

12 years ago
some suspects:
Bug 199569 (fancy this - originally filed against bugzilla:querylist)
Bug 139021
Bug 187550
(Reporter)

Comment 14

12 years ago
Created attachment 223604 [details]
Truncated bug list screenshot.
(Reporter)

Comment 15

12 years ago
Created attachment 223605 [details]
Truncated bug list source code.
(Reporter)

Comment 16

12 years ago
I stand corrected - it just happened to me again (Firefox 1.5.0.3 on Win XP), and the source code (attachement 223605) shows that all the bugs are there but don't seem to be rendered for one reason or another (attachement 223605).  Can somebody please verify this with the source code?  If this is a Firefox bug indeed then I'm happy to open up a Firefox bug.  :-)
(Reporter)

Comment 17

12 years ago
(In reply to comment #16)
> I stand corrected - it just happened to me again (Firefox 1.5.0.3 on Win XP),
> and the source code (attachement 223605) shows that all the bugs are there but
> don't seem to be rendered for one reason or another (attachement 223605).  Can
> somebody please verify this with the source code?  If this is a Firefox bug
> indeed then I'm happy to open up a Firefox bug.  :-)

And when I clicked "Refresh" the bug list was show correctly.

Comment 18

12 years ago
Yeah, okay, then. It's INVALID only because it's not a Bugzilla bug, but a Firefox bug. Feel free to file a Firefox bug and reference this one.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.