In the tinderbox page, Clicking a uri for a contribution with a contributor's name, which shows a menu of what a contributor checked in, may show instead the menu for the contributor you've just previously observed.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: crf, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060125 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060125 SeaMonkey/1.5a

Included is a screenshot of what I witness.

If I go to tinderbox, and, noticing on the left a list of contributions to the cvs, click the name of a contributor (the first contribution) to bring up a pop up menu, then click in that popup menu to go somewhere, then go back to the tinderbox page, then fairly quickly click the name associated with a second contribution, the menu which pops up is that for the first contribution, and the links are those for the first contribution. 

If I wait a while before clicking the link for the second contribution, the tinderbox page will visible redraw itself a few times (it appears to shudder), and the links shall then be correct.

I do not think this behaviour was present in 20060123 build.

Reproducible: Always

Steps to Reproduce:
1.Visit tinderbox, click on a contribution to display a popup window with a menu, navigate using the menu, then go back to tinderbox.
2.Click on a second contribution fairly quickly after navigating back to tinderbox. The menu displayed for that second contribution shall erroneously be that of the first contribution.
3.



Expected Results:  
The menu displayed for the second contribution should be that for the second contribution, rather than that of the first contribution.
(Reporter)

Comment 1

12 years ago
Created attachment 209677 [details]
image showing error, with explanations.

Comment 2

12 years ago
worksforme with linux seamonkey trunk build 2006012603
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
Works for me with later build now as well.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20060127 SeaMonkey/1.5a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.