Crash when clicking a link with a long href url

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: robzilla, Assigned: Scott MacGregor)

Tracking

({stackwanted, testcase})

x86
Windows XP
stackwanted, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
I got a HTML message with a link to a really long URL in it (976 chars).

When I click on the link, Thunderbird crashes hard - the window just disappears, and I don't even get the Talkback window or the Microsoft "Send Error Report" thingy.
(Reporter)

Comment 1

13 years ago
Created attachment 209698 [details]
test case

Open the attached using File->Open Saved Message, then click on the link.

The only extensions I have installed are Mozilla Calendar 0.2.0.20060116 and Talkback 1.5

Comment 2

13 years ago
I tried this with a trunk build - it worked fine and loaded the url successfully in firefox. So someone else will have to try to reproduce this, but I suspect something in your setup

Updated

13 years ago
Keywords: stackwanted

Comment 3

12 years ago
This is actually reproducible, but unfortunately not in every computer (or system).  I've installed the nightly build, and it still cause the same problem.

System that fails:
I have a Pentium D 840 desktop with, 1 gig ram.
windows xp media center, version 2002 sp2.
Nightly build thunderbird on July 14, 2006, 12:00 PM PST
fails with thunderbird version 1.5.0.4 with stranger resutl:
- sometimes crashes instantly 
- when not crashes, the pull down main menu is not hightlighted incorrectly, and no other links can be opened.

System that works:
Laptop Pentium M 1.4 GHz Samsung, windows xp home ed, sp2.
works fine with version 1.5.0.4

Don't know why it works, don't know why it fails.
Wasn't sure at first that this is a bug, until I see this thread.
Hopefully someone on the dev side can reproduce this bug.

Comment 4

12 years ago
Rob, getting a Talkback ID for the crash would help us here, too. http://kb.mozillazine.org/Talkback
(Reporter)

Comment 5

12 years ago
Sorry, I can't reproduce it anymore.  I originally reproduced it at work, but I use outlook now and don't have TB installed.  At home, TB doesn't crash.

Andreas, are you able to help?

Comment 6

12 years ago
Created attachment 229293 [details]
details saved from talkback crash report

Comment 7

12 years ago
Yes of course,
I've attached the latest details.  I've submitted 3 crash report with id:
TB20959450W, TB20955740M, TB20955630X

In general, does submitting multiple crash report on the same bug cause confusion?  Should I just restrain to only submit 1?

Comment 8

12 years ago
Hrm... those stacks aren't very useful. Can you try installing a different version of Thunderbird and crashing again?

Also, what are you using to test this, Andreas? The testcase in the bug?

(As for submitting IDs, it probably won't hurt to submit as many as you want, but if you're crashing every 5 minutes then it's probably just best to submit only a few.)

Comment 9

12 years ago
The case I use is different.  here it is
http://e.staples-deals.com/passthru.aspx?c=232&prod_id=107009&status_id=4012030645&redirectURL=http%3A%2F%2Fwww%2Estaples%2Ecom%2Fwebapp%2Fwcs%2Fstores%2Fservlet%2FStaplesCategoryDisplay%3FstoreId%3D10001%26langId%3D%2D1%26catalogIdentifier%3DHC2%26identifier%3DHC2%26cm%5Fmmc%3Demail%5Fretail%2D%5F%2Dcons%5Fchainwide%5F071406%2D%5F%2DBusiness%5FCustomer%2D%5F%2DSpecials%5FTab%26cm%5Flm%3Dex%3AAMANTIK%40UCLA%2EEDU

but when i use the test case on this page, it crashes also, so I thought the problem is similar.

i've just installed version 1.5.0.4 back
it is harder to crash the thunderbird in this version, but like I said,
after clicking the link (on both test case) it doesn't want to open other links.  Even after I close tb, it doesn't remove itself from the process, and talkback doesn't think it as a crash.  Here is the two crash id I got related to this TB20961206Y, TB20954572H.

Thanks for looking into this matter
QA Contact: front-end
see also Firefox2/Linux bug 371343 - crash clicking on a long link. Related? Different product, different version, different platform... but similar symptoms.

Comment 11

11 years ago
Andreas, unfortunately your talkback ids have aged off the database. Can you repeat and post a new talkback id, using a current version of thunderbird (or trunk)?

attachment 229293 [details] WFM version 3.0a1 (20070421)

Comment 12

11 years ago
After installing v2 Thunderbird the problem disappears (at least in mine).  I hope it does the same with everyone.  Sorry can't provide with talkback id for those who curious what really happened.

Comment 13

11 years ago
test message from comment 1 works FM.  And in comment 5 reporter Rob is says he's not in a position to test. so closing this WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

11 years ago
Ya, doesn't crash for me anymore (TB 2.0.0.0)
You need to log in before you can comment on or make changes to this bug.