Page doesn't load/loads incorrect

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
10 years ago

People

(Reporter: sander, Assigned: dcone)

Tracking

({testcase})

Trunk
x86
Windows 95
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The above url works fine with navigator and explorer but not with m14.

Expected result is fanpage with a few photos.
When I tried this afternoon the page loaded unrecgonizably incorrect. With large
colourfull planes. Just now the page took forever to render.

Javascript is just a wild guess.

(i run m14 on win95)

Comment 1

19 years ago
Just tried with 3/20 build. Page rendered as completely black page except for a 
few images at the bottom. 
Assignee: rogerl → kmcclusk
Component: Javascript Engine → Compositor
QA Contact: rginda → petersen

Comment 2

19 years ago
marking confirmed, the javascript ect on the page is ugly...
Status: UNCONFIRMED → NEW
Ever confirmed: true


Here is the stack trace when I break into it.

nsImageWin::Draw(nsImageWin * const 0x02cb1dd0, nsIRenderingContext & {...}, 
void * 0x037e7f70, int 492, int 6, int 1, int 2) line 515
nsRenderingContextWin::DrawImage(nsRenderingContextWin * const 0x0398f760, 
nsIImage * 0x02cb1dd0, const nsRect & {...}) line 2609
nsRenderingContextWin::DrawImage(nsRenderingContextWin * const 0x0398f760, 
nsIImage * 0x02cb1dd0, int 7380, int 90, int 15, int 30) line 2586
nsCSSRendering::PaintBackground(nsIPresContext * 0x037d0b00, nsIRenderingContext 
& {...}, nsIFrame * 0x0297fa18, const nsRect & {...}, const nsRect & {...}, 
const nsStyleColor & {...}, const nsStyleSpacing & {...}, int 0, int 0) line 
2368
nsBlockFrame::Paint(nsBlockFrame * const 0x0297fa18, nsIPresContext * 
0x037d0b00, nsIRenderingContext & {...}, const nsRect & {...}, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 5876 + 37 bytes
nsContainerFrame::PaintChild(nsIPresContext * 0x037d0b00, nsIRenderingContext & 
{...}, const nsRect & {...}, nsIFrame * 0x0297fa18, nsFramePaintLayer 
eFramePaintLayer_Underlay) line 227
nsContainerFrame::PaintChildren(nsIPresContext * 0x037d0b00, nsIRenderingContext 
& {...}, const nsRect & {...}, nsFramePaintLayer eFramePaintLayer_Underlay) line 
167
nsHTMLContainerFrame::Paint(nsHTMLContainerFrame * const 0x0297ed44, 
nsIPresContext * 0x037d0b00, nsIRenderingContext & {...}, const nsRect & {...}, 
nsFramePaintLayer eFramePaintLayer_Underlay) line 89
PresShell::Paint(PresShell * const 0x03013d84, nsIView * 0x03352ad0, 
nsIRenderingContext & {...}, const nsRect & {...}) line 3276 + 34 bytes
nsView::Paint(nsView * const 0x03352ad0, nsIRenderingContext & {...}, const 
nsRect & {...}, unsigned int 128, int & 50270480) line 289
nsViewManager2::RenderDisplayListElement(DisplayListElement2 * 0x0335ab40, 
nsIRenderingContext & {...}) line 803
nsViewManager2::RenderViews(nsIView * 0x03353280, nsIRenderingContext & {...}, 
const nsRect & {...}, int & 0) line 750
nsViewManager2::Refresh(nsIView * 0x03353280, nsIRenderingContext * 0x0398f760, 
const nsRect * 0x0012f8f4, unsigned int 1) line 628
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x02ff1110, nsGUIEvent * 
0x0012fa34, nsEventStatus * 0x0012f938) line 1270
HandleEvent(nsGUIEvent * 0x0012fa34) line 69
nsWindow::DispatchEvent(nsWindow * const 0x03353154, nsGUIEvent * 0x0012fa34, 
nsEventStatus & nsEventStatus_eIgnore) line 498 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fa34, nsEventStatus & 
nsEventStatus_eIgnore) line 524
nsWindow::OnPaint() line 2985 + 28 bytes
nsWindow::ProcessMessage(unsigned int 15, unsigned int 0, long 0, long * 
0x0012fd38) line 2178 + 17 bytes
nsWindow::WindowProc(HWND__ * 0x036c06a6, unsigned int 15, unsigned int 0, long 
0) line 676 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()

Don, this page is caught in the slow blitting code path in the tiling code. 
Assignee: kmcclusk → dcone
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 4

19 years ago
Tiling is fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
With the July 6th Win 32 build (under Win 98), the url is rendered as a blank 
page.Reopening bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

19 years ago
This page hangs.. but if I turn applets off.. the page will load with nothing 
rendered.  On the Mac it will crash.. no stack trace.  I think this is a Java 
problem.. at least the part of it hanging, 
Patrick can you triage this..I have no idea who the owner of Java is, or who 
should look at this.. I have this feeling you might know who gets this.  
Thanks.. 
Assignee: dcone → beard
Status: REOPENED → NEW

Comment 7

19 years ago
The page loads fine with Java disabled in Mac Communicator 4.72, so Java isn't 
providing any important content. If I load this page with the MRJ plugin with MRJ 
2.2.2, I get a pretty nasty crash. I'd recommend tackling the problem with the 
MRJ plugin removed altogether from the Plugins folder.
Assignee: beard → dcone
I dont think this is a Mozilla bug. The original page looks like:
<SCRIPT>
if (navigator.userAgent.indexOf("Mozilla/3") != -1) {
	document.write('<frameset border=');
        // etc ...
} else if (navigator.userAgent.indexOf("Mozilla/4") != -1) {
	document.write('<frameset border=');
        // etc ...
}
</SCRIPT>
// rest of page - which makes no sense without the frames above...

I have attached a testcase to prove my point, which is a copy of the original
URL where I changed: 
1. Adding a <base href>
2. Changing "Mozilla/4" to "Mozilla/5" in the SCRIPT.

And the page loads fine in build 2000-07-20-08 on Windows 98 SE at least.

IMO this bug is invalid.
Keywords: testcase
(Assignee)

Comment 10

19 years ago
I agree with Mats
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID

Comment 11

19 years ago
Marking verified invalid.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.