Runaway Print Jobs - when print without click in frame first

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: wendy.gross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

In Firefox, I've discovered if you try printing right away without
clicking on the top frame (where the tabs are) or the bottom frame
(where the main  content is), you'll suffer a run-away print job.Work 
around is to make sure you click on the bottom frame before attempting to
print.

I have experienced this problem in 1.0.1 and 1.5. And I have colleagues
how have experienced this same problem too.

Please let me know status of this bug.

I am enjoying using Firefox!

Cheers,
Wendy

Reproducible: Didn't try

Steps to Reproduce:
1. open a web page and print right away before clicking in any content of the page
2.
3.

Actual Results:  
Problem has happened twice to me and once to a colleague. I have not tried to reproduce, because when it happen, hundreds of pages of paper were wasted and my printing resources are shared with about 200 people.
Can you give more details on what happens instead of printing the page?
(Reporter)

Comment 2

12 years ago
the first phyical page of the print job prints over and over again until the job is killed.

I am a graduate student at Penn State University through their World Campus.
This problem happened to me twice and a class-mate once - then tech support
at Penn State was able to reproduce it and make recommendation to
click in frame before attempting to print.

I ask the tech support person at Penn State to add any aditional information
they have to this bug report.

Comment 3

12 years ago
Maybe related to Core bug 288619?

Comment 4

12 years ago
Created attachment 235093 [details]
is a .zip file containing six .html files that trip the bug

frameset1.html creates two frames:
  frame1a.html
  frame1b.html

frameset2.html creates two frames:
  frame2a.html
  frame2b.html

Load frameset1.html in firefox 1.5.0.6 on windows XP, then click "click to load frameset2". If you immediately File..Print (without clicking a frame to gain focus) it will spool many, many, many pages to the printer.

Comment 5

12 years ago
I work for a large university and we have seen this bug.

We've determined that this only surfaces when in "nested" framesets.

We are able to reproduce this bug on many different windows XP machines, all running Firefox 1.5.0.6, and printing to several different printers.

Also, this bug is not present on FF 1.5.0.6 for Mac.

Attached is .zip file containing six .html files that trip the bug.

frameset1.html creates two frames:
  frame1a.html
  frame1b.html

frameset2.html creates two frames:
  frame2a.html
  frame2b.html

Load frameset1.html in firefox on windows XP, then click "click to load frameset2". If you immediately File..Print (without clicking a frame to gain focus) it will spool many, many, many pages to the printer.

Comment 6

11 years ago
I have duplicated this issue in 1.5.0.8 and 2.0 on Windows. It does not occur in 3.0a1. It does not occur in 1.5.0.8 or 2.0 on MacOS.

More information: if the print job is canceled in 2.0, a dialog is displayed that states "Printing failed when completing the page." This dialog cannot be dismissed. This locks up the browser, forcing the user to kill it manually.

This causes serious problems in our university computer labs, where students are charged per page for printing. Because our course management system triggers this bug, it is usually erroneously perceived as a problem with our course management system, rather than Firefox. 

It looks like multiple users can replicate this bug. Could someone please mark it as confirmed?

Comment 7

11 years ago
This really should be marked confirmed. Can someone who has the access rights to do that please do so?
Well it looks like the summary needs refining, this only happens with "nested" frames?  Also, if it doesn't happen in 3.0a1 then this can be resolved fixed or WFM.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

11 years ago
I was able to circumvent the problem by adding onLoad="self.focus();"  to the body tag of the page that would want to be printed (ie. <body onLoad="self.focus();">) Not a fix per se but it might be useful...

Comment 10

11 years ago
Runaway print jobs from Firefox are causing my computer lab managers some serious grief.  Has anyone made progress on this bug?

Comment 11

11 years ago
Created attachment 278968 [details]
javascript can trigger the error.

set of simple html files that demonstrates the error.

Comment 12

10 years ago
Dean, your attachment appears to be corrupted. Can you upload another copy?

Comment 13

10 years ago
Created attachment 300654 [details]
re-submit of javascript that trigger the error.
Attachment #278968 - Attachment is obsolete: true

Comment 14

8 years ago
With the attached testcase:
1. doing File-Print without clicking/selecting any frame in the page, print only Frame 0;
2. doing File-Print after clicking/selecting a specific frame in the page, print only that frame.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Comment 15

4 years ago
With attachment 300654 [details] I can't reproduce the symptoms described using 31.0a1 (2014-04-15) on vista. Although frameset 1b does not appear in the print. (a different bug)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.