Bookmarks toolbar overflow menu briefly shows recent history on first load

RESOLVED DUPLICATE of bug 331297

Status

()

RESOLVED DUPLICATE of bug 331297
13 years ago
10 years ago

People

(Reporter: waynegwoods, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
This OS X bug has some similarities to the Windows bug 285476. The symptoms are not the same, but it's the closest I can find.

To reproduce, you need to have more items than will fit in the Bookmarks Toolbar, so that the chevron for the overflow menu appears.

Open a new window. Click on the chevron. For a split second, the wrong menu appears. It then changes to display correctly (i.e. the bookmarks that wouldn't fit on the toolbar). As far as I can tell, the bad items that it displays initially are from the "Go" menu, i.e. recent history.

If you try it again, the bad menu won't appear. You have to open a new window to reproduce.

I've reproduced in the latest trunk nightly using a fresh profile. The bug stretches back at least as far as 2004 builds, which makes me suspicious of not being able to find a dupe.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 308030 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 331297 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.