Superreview flag changes do not end up in mozilla.dev.super-review

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: mcsmurf, Assigned: justdave)

Tracking

Details

(Reporter)

Description

13 years ago
If you have requested/granted/cancelled/denied superreview (sr) on a patch on bugzilla.mozilla.org a copy of the mail which got sent to the requestee ended up in the newsgroup netscape.public.mozilla.reviewers as well. As a example look at this mail:
------
Path: local01.nntp.dca.giganews.com!nntp.mozilla.org!news.mozilla.org.POSTED!not-for-mail
NNTP-Posting-Date: Sat, 21 Jan 2006 11:15:06 -0600
Date: Sat, 21 Jan 2006 09:13:54 -0800
Subject: superreview requested: [Bug 258006] Mouse-wheel scroll events does not propagate to viewport from fixed pos. elements :  [Attachment 209211 [details] [diff]] Patch rv1.0
From: bugzilla-request-daemon@mozilla.org
Sender: mozilla-reviewers-admin@mozilla.org
Errors-To: mozilla-reviewers-admin@mozilla.org
X-BeenThere: mozilla-reviewers@mozilla.org
X-Mailman-Version: 2.0.13
Precedence: bulk
List-Help: <mailto:mozilla-reviewers-request@mozilla.org?subject=help>
List-Post: <mailto:mozilla-reviewers@mozilla.org>
List-Subscribe: <http://mail.mozilla.org/listinfo/mozilla-reviewers>,
	<mailto:mozilla-reviewers-request@mozilla.org?subject=subscribe>
List-Id: <mozilla-reviewers.mozilla.org>
List-Unsubscribe: <http://mail.mozilla.org/listinfo/mozilla-reviewers>,
	<mailto:mozilla-reviewers-request@mozilla.org?subject=unsubscribe>
Errors-To: mozilla-reviewers-admin@mozilla.org
X-BeenThere: mozilla-reviewers@mozilla.org
Newsgroups: netscape.public.mozilla.reviewers
Message-ID: <mailman.1137863702.25583.mozilla-reviewers@mozilla.org>
X-Original-Cc: reviewers@mozilla.org
X-Original-To: roc@ocallahan.org
Approved:  newsATmozilla.org
Lines: 18
NNTP-Posting-Host: 207.126.111.202
X-Trace: sv3-Wrffk4fYD6E0x8rHl6tzUWLzDjLC9TBIS3irpYDaJ/AutY4pKYxavPyCS8lxrh1BKz4HKFubAGOqkaL!2T0hvJn5kRukewybvzXIJn1sme/WLmG5a3lH1fhvH8JiaIULb2XavV1GHtm1bvCSywBsLGNhuIc4!OUc9xjXMrcIO1EHfEQseYFn+aAy3
X-Complaints-To: abuse@mozilla.org
X-DMCA-Complaints-To: abuse@mozilla.org
X-Abuse-and-DMCA-Info: Please be sure to forward a copy of ALL headers
X-Abuse-and-DMCA-Info: Otherwise we will be unable to process your complaint properly
X-Postfilter: 1.3.32
Xref: number1.nntp.dca.giganews.com netscape.public.mozilla.reviewers:42639

Masayuki Nakano (Mozilla Japan)(busy) <masayuki@d-toybox.com> has asked Robert
O'Callahan (Novell) <roc@ocallahan.org> for superreview:
Bug 258006: Mouse-wheel scroll events does not propagate to viewport from fixed
pos. elements
https://bugzilla.mozilla.org/show_bug.cgi?id=258006

Attachment 209211 [details] [diff]: Patch rv1.0
https://bugzilla.mozilla.org/attachment.cgi?id=209211&action=edit

------- Additional Comments from Masayuki Nakano (Mozilla Japan)(busy)
<masayuki@d-toybox.com>
On current code, the most ancestor frame of inner fixed positioned frame is not
document root frame. Therefore, in this case, the scrollable frame is not found
on current document if the fixed positioned context doesn't have scrollable
view.

Therefore, my patch processes like as the parent frame of root frame of fixed
positioned view is document root frame.
------

Now after the newsgroup re-org those mails should end up in mozilla.dev.super-review, but no postings end up there. Maybe it has a problem with the (moderated, auto-post) status of this group?
(Reporter)

Comment 1

13 years ago
(In reply to comment #0)
> up in the newsgroup netscape.public.mozilla.reviewers as well. As a example
> look at this mail:
              ^^^^^^
Make that newsgroup post, i looked at a post in the old newsgroup netscape.public.mozilla.reviewers
I noticed this right after we switched it over, and made a few (apparently unsuccessful) attempts to get it working.  Unfortunately I then left for vacation.  I'm planning to hack on it again when I get back (Monday).

I have no idea where it's disappearing, the address it mails to (which successfully posted to the old newsgroup) is now forwarded to the posting address for the new group.  The new group is set up to auto-approve any posts from about 6 different variations of addresses known to be used by Bugzilla, and forward everything else to the moderator.  I (moderator) have never received any super-review requests, however I receive lots of spam that was sent to the old address and forwarded.  Which makes it sound like things are just disappearing into the ether somewhere and it's really weird...
oh, and dev-crypto-checkins is set up exactly the same way, and it works fine...
Assignee: server-ops → justdave
Priority: -- → P1
OK, first problem is that the address the mail was coming from was subscribed to the list.  And the list was set to discard all posts from members.  So I unsubscribed it.  Then they were getting held instead of auto-posted.  Changed the list policy from moderated to open with moderated list, which apparently is the same thing, just changes the order of the moderation filters.  Now it seems to be working.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.