calXmlExporter [extension fodder]

VERIFIED WONTFIX

Status

Calendar
Import and Export
--
enhancement
VERIFIED WONTFIX
13 years ago
10 years ago

People

(Reporter: Sean McMurray, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

A quick ripoff of calHtmlExporter to provide an XML export interface.

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 209945 [details]
Provide XML Exporter similar to calHtmlExport.js

I'm trying to shadow the interface used in calendar printing to provide something closer to the gui views. This interface extracts event data as XML, allowing pluggable XSL stylesheets to render different printable SVG views.
(Reporter)

Comment 2

13 years ago
Created attachment 209946 [details] [diff] [review]
calXmlExport.js

oops. Note to self: Save, then upload.
Attachment #209945 - Attachment is obsolete: true

Comment 3

13 years ago
Comment on attachment 209946 [details] [diff] [review]
calXmlExport.js

Hmm... looks interesting.  The person to talk to about this sort of thing would be mvl, since he wrote all of the current import/export code.  When you think you've got the code in good shape, you're going to need to create a diff file that contains all of the code changes (as well as this new file) that need to be made to have this exporter work in Sunbird/Lightning.  Then you should attach that diff file and ask for review from someone, probably mvl.  More info on this process is available at http://wiki.mozilla.org/Calendar:Hacking  (You can skip to section 1.4.)

One thought on the actual code is whether or not there are any standards or guidelines out there for how to create calendar data in xml format.  I know that eventful.com will export events in an xml format, but at a quick glance, it doesn't look like their output will agree with this one.  Are there other services out there that provide xml exporting?  How do they structure the data?
(Reporter)

Comment 4

13 years ago
Now there needs to be edits to
   resources/content/calPrintEngine.js#182
that use the XML instead of the text-dump html.

These changes need to reflect choices made about format in
   resources/content/printDialog.xul
and observed in
   resources/content/printDialog.js#107
The patch seems to only include a few fields, while in xml you can easily include all data from the event. I would expect that exporting to xml would be loss-less.
And iirc, there is some xml version of iCalendar, maybe you should try to use that.

Comment 6

12 years ago
*** Bug 163466 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
*** Bug 162688 has been marked as a duplicate of this bug. ***
Component: Sunbird Only → Import and Export
OS: Linux → All
QA Contact: sunbird → import-export
Hardware: PC → All
This is a very specific request, so the best way to offer it is an extension. -> WONTFIX & [extension fodder]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Summary: calXmlExporter → calXmlExporter [extension fodder]

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.