crash when autofill suggestions aren't selected

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: pcooke2003, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Firefox crashes when autofill suggests previously used search terms and you continue to type in your new search term.  Same problem occurs with gmail -- When composing subject line of email message, various previously used subjects appear below for you to choose from.  If you continue to type rather than selecting one when those other options are visible, Firefox crashes.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
happens very often - i don't know if every time but i don't want to try it now because this form will close and i'll have to start the whole process over!

Comment 1

13 years ago
Could you install with talkback and get a talkback ID for the crash? http://kb.mozillazine.org/Talkback
Keywords: crash

Comment 2

13 years ago
Reporter, are you using Mac OS X 10.2.8 ? Then it's bug 298502. Please upgrade to Firefox 1.5.0.1 when it's ready next week.

Comment 3

13 years ago
I can add my name to the list in that Firefox invariably crashes in these instances. I noticed the following line that Jo Hermans added on this issue:

Reporter, are you using Mac OS X 10.2.8 ? Then it's bug 298502. Please upgrade
to Firefox 1.5.0.1 when it's ready next week.

I am using Mac OS 10.2.8, and I have been running 1.5.0.1 since it came out, but the problem persists. In case you need other information about my system:

15" flat-panel iMac (first edition)
700 MHz G4
40 GB hard drive, 4.5 GB free
768 MB RAM

This occurs on various sites when entering something into a text field (forgive my lack of technical knowledge on these matters). As I begin to type, a menu comes up just under the box suggesting other entries I have made in the past. It seems to me that it only occurs with two or more suggestions. Here are the steps  on my system.

1. Go to www.yellowpages.com -- I chose this site because I was just trying to use it and it would not work.

2. Without changing any of the other options, type an entry in the first field (under business category). You must have made some entries in the past that will be saved. They should start with the same letter as the current entry you are typing.

3. Typing the first letter (in my case an S) will automatically bring up a list of any other entries that begin with that letter that have been made in the past. Typing the second letter will immediately cause Firefox to become unresponsive.

The program will remain that way for hours or until you lose patience. The only option is to force the program to quit. As someone has noted, since this doesn't count as a crash, a report through talkback wouldn't be sent.
(Reporter)

Comment 4

13 years ago
I'm still having problems with the auto-fill crash, too, and am tired of it!!!!!  Hope it will get fixed soon!!!!!

Comment 5

13 years ago
The problem is fixed in 1.5.0.2! I tried the steps that I outlined above, and it worked without a problem. Before this update, the program would freeze without fail when following those steps.

Comment 6

13 years ago
Reporter, are you still having this problem with 1.5.0.2 or later?

Comment 7

13 years ago
(In reply to comment #6)
> Reporter, are you still having this problem with 1.5.0.2 or later?
> 

It used to crash without fail, but I have not seen it happen once since 1.5.0.2, and that includes the current 1.5.0.4. The problem seems to be fixed.

Comment 8

13 years ago
Thanks, Garrett. Resolving WORKSFORME since we don't know for sure which patch fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.