If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PNG image cannot be displayed because it contains errors

VERIFIED DUPLICATE of bug 283214

Status

Core Graveyard
Image: Painting
VERIFIED DUPLICATE of bug 283214
12 years ago
8 years ago

People

(Reporter: JConley, Assigned: Stuart Parmenter)

Tracking

({testcase})

1.8 Branch
x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060125 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060125 Firefox/1.5.0.1

I have a PNG image that cannot be viewed by 1.5 or Trunk (Jan2006)
It shows "image [name] cannot be displayed because it contains errors"

This image works in Firefox 1.0.7, IE 6/7, Opera 8.51, Photoshop, MsPaint and viewers like MSViewer/FastStone.

Reproducible: Always

Steps to Reproduce:
see attached png image
(Reporter)

Comment 1

12 years ago
Created attachment 209988 [details]
image
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5 Branch

Updated

12 years ago
Component: General → Image: GFX
Keywords: testcase
Product: Firefox → Core
Version: 1.5 Branch → 1.8 Branch

Updated

12 years ago
Assignee: nobody → pavlov
QA Contact: general

Comment 2

12 years ago
Marking as dupe, feel free to reopen if the other doesn't solve this one.
png could be seen with irfanview, saved from irfanview it got a bit larger, and could be seen with seamonkey. Info in irfanview didn't show a difference besides the size.
 
Bug 283214 Zlib decoding of PNG isn't as forgiving as 1.8a1

*** This bug has been marked as a duplicate of 283214 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.