Getting a lot of WARNING: BOGUS code reached! in gtk2/nsWindow.cpp

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
Widget: Gtk
P3
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Assigned: mrbkap)

Tracking

Trunk
mozilla1.9alpha1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When using sunbird, but from #developers also in other apps, i get a lot of WARNING: BOGUS code reached!, file /home/michiel/mozhack/tree1/mozilla/widget/src/gtk2/nsWindow.cpp, line 578
I'm not sure when, it seems to be when moving or creating windows.
It is getting pretty annyoing, because it makes other debug output much harder to find.

Comment 1

12 years ago
stack in attachment 209429 [details]
Depends on: 297541
QA Contact: gtk → roc
Confirmed to also be happening with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060218 Firefox/1.6a1 ID:2006021813.
Very annoying. :(
(Assignee)

Comment 3

12 years ago
Created attachment 212977 [details] [diff] [review]
Remove it
Assignee: nobody → mrbkap
Status: NEW → ASSIGNED
Attachment #212977 - Flags: superreview?(roc)
Attachment #212977 - Flags: review?(roc)
Attachment #212977 - Flags: superreview?(roc)
Attachment #212977 - Flags: superreview+
Attachment #212977 - Flags: review?(roc)
Attachment #212977 - Flags: review+
(Assignee)

Comment 4

12 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9alpha
You need to log in before you can comment on or make changes to this bug.