Lightning broken in nightlies: views & toolbar buttons do not appear.

RESOLVED FIXED

Status

Calendar
Lightning Only
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: gekacheka, Assigned: Joey Minta)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060129 Thunderbird/1.6a1 Lightning/0.0.1+ 20060129

In 20060129 TB build + lightning xpi (windows) from 
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-trunk/

The views do not appear when you click on a date in the minimonth, and 
the lightning toolbar buttons (for creating items and switching views) do not appear in the toolbar, and are not in the customize views pane.



Reproducible: Always

Steps to Reproduce:

Actual Results:  
On startup, lightning toolbar buttons do not appear in toolbar,
and clicking on a date in minimonth does not switch to lightning view.

The javascript console shows only one suspicious error:
  Error: gSearchBox is not defined
  Source File: chrome://lightning/content/messenger-overlay-sidebar.js 196
later, line 113.

Expected Results:  
lightning toolbar buttons should appear.
lightning view should appear when clicking on date in minimonth.

The bug that removed gSearchBox seems to be bug 324194.

A larger concern:  This means that 1.8 TB and 1.9 TB are diverging.
I hope this doesn't mean maintaining two Lightning xpi's.

Comment 1

12 years ago
Created attachment 210145 [details] [diff] [review]
do forward check for gSearchBox

Patch was tested with Thunderbird 1.5 and current trunk version.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #210145 - Flags: first-review?(jminta)
(Assignee)

Comment 2

12 years ago
Created attachment 210178 [details] [diff] [review]
hide the search box regardless of version

Stealing bug after discussion on IRC.  In the long-run we need to decide on the best thing to do with the search-bar from a user-perspective, but this should get things running again for everyone until that decision can be made.
Assignee: ssitter → jminta
Attachment #210145 - Attachment is obsolete: true
Attachment #210178 - Flags: first-review?(dmose)
Attachment #210145 - Flags: first-review?(jminta)

Comment 3

12 years ago
Comment on attachment 210178 [details] [diff] [review]
hide the search box regardless of version

r=dmose
Attachment #210178 - Flags: first-review?(dmose) → first-review+
(Assignee)

Comment 4

12 years ago
(In reply to comment #3)
> (From update of attachment 210178 [details] [diff] [review] [edit])
> r=dmose
> 

My hard-drive died.  Can someone check this in for me?  Thanks.

Comment 5

12 years ago
Doh; sorry to hear about your hard-drive!  I've landed the patch.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 305578 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.