Cursor jumps to the beginning of a line

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Sy Ali, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Firefox/1.5

Cursoring in a textbox has changed.  Regular cursoring now results in the cursor hopping to the beginning of a line, making it infuriating to do common editing.  Now a lot of extra cursoring, ctrl-cursoring or mouse clicking (ugh) is required to edit the middle of a "column" of several lines of text.

Reproducible: Always

Steps to Reproduce:
1. Type two equal-length lines of text into an edit field.
2. Cursor to the middle of the topmost sentence.
3. Cursor down.

Actual Results:  
The cursor hops to the beginning of the line.

Expected Results:  
The cursor should stay where it is horizontally, but move down one line.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20060128 Firefox/1.5 ID:2006012803
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060129 Firefox/1.6a1 ID:2006012914
WFM
(Reporter)

Comment 2

12 years ago
Works for me, with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050317 Firefox/1.0.7
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Closing this bug, as it's resolved with the most recent version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

12 years ago
It seems to have broken again with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060201 Firefox/1.5.0.1

I won't re-open this unless I get confirmation that someone else is seeing this problem.

Comment 4

12 years ago
I can confirm that this bug is present in

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060310 Ubuntu/dapper Firefox/1.5.0.1
(Reporter)

Comment 5

12 years ago
This bug seems to be resolved "for real" with a newer version of Firefox:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060728 Firefox/1.5.0.5

I have made no changes in my extensions except to update them.  It's possible it was an extension update that resolved a bug in an extension, or it was the Firefox update which resolved a bug in either Firefox or in an extension.  =)

Andy, would you try updating to see if this problem is also fixed for you?

Comment 6

12 years ago
(In reply to comment #5)
> 
> Andy, would you try updating to see if this problem is also fixed for you?
> 

Yep, works for me :)

Comment 7

12 years ago
As I commented in [url=https://bugzilla.mozilla.org/show_bug.cgi?id=343927]this bug[/url], I have this problem in 1.5.0.5. And, not only in Firefox, but also in Thunderbird.

Comment 8

11 years ago
FYI, there is a patch for this at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198759
You need to log in before you can comment on or make changes to this bug.