Closed Bug 325159 Opened 14 years ago Closed 14 years ago

Ctrl+click on richlistitem doesn't deselect it.

Categories

(Toolkit :: XUL Widgets, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: waymost+firefox, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060123 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060123 Firefox/1.5

When you control-click on the richlistitem that is already selected, e.g. an extension in the EM, it should be deselected. However, the item remains selected. Even though <richlistbox> doesn't support multiple selections, this Ctrl-click behavior should still occur on the selected item (and there is code in the richlistitem click handler that is supposed to do this, which apparently doesn't work).

Reproducible: Always

Steps to Reproduce:
1. Open up EM.
2. Select an item if none is already selected.
3. Hold down Control key and click on the selected item.

Actual Results:  
Nothing happens.

Expected Results:  
Item should be deselected.
WFM unless I have Console2 extension installed. Are you sure it's not an extension problem?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1

Works for me, too.
I thought I was running a clean profile, but alas, Console2 was there. Upon creatng a new profile, the problem ran away.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
What you uncovered here seems to be a bug in richlistbox which doesn't exist in Console²'s richlistbox implementation: bug 325235. Console² 0.3.3 will (at least temporarily) fix this bug, but I'd still be interested in why you need this functionality at all...

If you don't want Console² to interfere with your richlistbox (it currently adds FAYT to the Extensions/Themes/Downloads managers), simply remove the indicated lines in this extension's chrome.manifest.
You need to log in before you can comment on or make changes to this bug.