Rewrap command doesn't work with long lines

RESOLVED DUPLICATE of bug 187997

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 187997
12 years ago
10 years ago

People

(Reporter: Rotis, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: TB version 1.5 (20051201)

The Rewrap command rarely works satisfying. For example, two extra long lines without any breaks like Outlook sends them occasionly/always:

> this is a extra super idiotic and foolish long line long extra long .....
> here comes the second unbroken line like stupid mailers do send .....

Now I rewrap them with Thunderbirds Rewrap command. This is the result (example from above):

> this is a extra super
idiotic and foolish long
line long extra long .....
> here comes the second
unbroken line like stupid
mailers do send .....

You see? They get rewrapped at the correct length but there are no quote marks (>) added. A lot of handwork must be done to correct that.

Reproducible: Always



Expected Results:  
Expected functionality is correct setting of quote marks like this:

> this is a extra super
> idiotic and foolish long
> line long extra long .....
> here comes the second
> unbroken line like stupid
> mailers do send .....

Comment 1

12 years ago
Worksforme on linux.

Comment 2

12 years ago
This generally works for me under Windows 2000.  I think it's unlikely that the code handling this feature is going to behave differently under Mac and other OSes.

Reporter, are you still encountering this problem?  I'm assuming the problem occurred when you replied, but maybe not -- might it have happened when you forwarded a message?  There is a known problem with forwards not rewrapping properly, altho in my testing, a quote within a forward *is* rewrapped.

If you have a sample message that exhibits the problem, please save it as a 
.EML file and attach it to this bug, using the Create New Attachment link 
above.

Comment 3

12 years ago
On Linux, rewrap works nicely IFF your selected area includes at least one line that does *not* start with ">".  Expanding the OP's example:

> blah
>
> this is a extra super idiotic and foolish long line long extra long .....
> here comes the second unbroken line like stupid mailers do send .....
>
> blah

If you select only the middle two lines, it behaves as the OP complained.
Even if you select all 6 lines (being careful not to get the 7th as
well), it behaves as the OP complained.

Selecting 7 lines from the example behaves well.  A work-around is
inserting empty lines before you rewrap and fixing them after.  Rewraping
only part of the message is useful when it's part of a thread or when
you're replying point-by-point.

Comment 4

12 years ago
I'll assume Troy is correct, and that reporter was rewrapping a selection (something that should have been mentioned in the original report).

*** This bug has been marked as a duplicate of 187997 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.