phantom "window" entries in windows menu with task hang

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Darren Robinson, Unassigned)

Tracking

({hang})

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

firefox became unresponsive, failing to exit, despite apparently responding to controls. All but the last window closed using apple+shift+w, last window refused to close. All tabs closed (every last one!), tab bar was however still visible for some unknown reason. window continued to display one of the previously closed tabs (which seemed odd as this was not the last tab). checking in the window menu, found an extensive menu filled with nothing but blank menu items. the final tab title was displayed as the single (top most), and only menu item which was not blank. Title did not match the window displayed.

summary of features:
(1) closed tab still displayed in window
(2) emply tab bar remained visible
(3) menu item in windows menu displays incorrect title
(4) window menu displays large number of blenk/empty entries.
(5) firefox failed to close final window
(6) firefox failed to exit

Reproducible: Couldn't Reproduce

Steps to Reproduce:
Couldnt reproduce as had no way of knowing how this occured, firefox had been running fine, with no obvious signs of trouble, hence no reason to look in the "windows" menu on macosx.
(Reporter)

Comment 1

13 years ago
Bug #317499 may be related, as both bugs result in phantom windows being listed in the window menu, although some behaviour was a little different. Bug #325188 may also be related.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Keywords: hang
Whiteboard: CLOSEME 07/14
(Reporter)

Comment 3

11 years ago
Haven't noticed it since i first reported it, so may still be present. Bug was not possible to replicate. Will close. As this bug was never assigned to anyone and no comments were added it is reasonable to assume no-one did anything to fix the problem, so in combination with a difficult bug to trace it is impossible to say that the bug is 'Fixed'. However, if this is causing a problem in the bug reporting system I would be happy for it to be closed, as I assume development has stopped on the Firefox 1.5 (1.8.0.x) Branch, in which case the bug may never resurface even if not actually fixed.
Correct. The 1.5 branch is recently deceased. There would be no harm in keeping this bug open if you wish; we're just on a drive to close as many UNCONFIRMED bugs as is right to atm.
(Reporter)

Comment 5

11 years ago
I am closing this bug, however if it is possible to identify the likely reason why the issue reported herein happened it would be nice to know that it has at least been checked. I am surprised that more bugs that are only reported in a particular incarnation (i.e. Firefox 1.5) are not closed with a WontFix and a comment to say no further development happening on this incarnation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.