Closed Bug 325292 Opened 16 years ago Closed 13 years ago

col visibility:collapse shows cells in printing second page of a table

Categories

(Core :: Layout: Tables, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mozilla_bugs_1, Assigned: bernd_mozilla)

References

()

Details

(Keywords: testcase)

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Printing a table with 
<colgroup>
  <col></col>
  <col style='visibility:collapse'></col>
  <col></col>
</colgroup>
that goes over to a second page shows blank cells rather than suppressing them.  The first page is right. True in print preview as well.  See a simple sample at the test URL.

Reproducible: Always

Steps to Reproduce:
1.Load test page
2.File | Print Preview
3.Scroll to second or third page

Actual Results:  
data rows of : <tr><td>Show</td><td>Don't Show</td><td>do</td></tr>
on page one show: Show | do
on page two show: Show |____| do

Expected Results:  
all lines on page two to look like on page 1

I haven't found a work around, tried width:0px and the like, no good.
Assignee: nobody → printing
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch
Assignee: printing → nobody
Status: UNCONFIRMED → NEW
Component: Print Preview → Layout: Tables
Ever confirmed: true
QA Contact: layout.tables
Version: 1.8 Branch → Trunk
Attached file testcase
I guess http://lxr.mozilla.org/seamonkey/ident?i=AdjustForCollapsingCols is not called on the second page.
Keywords: testcase
Attached file Worse with <thead>
The problem appears worse with a <thead> section, the supposedly suppressed column's header is displayed on page 2 and later.
Duplicate of this bug: 356028
Confirmed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080903020504 Minefield/3.1b1pre
Platform --> All/All
OS: Windows XP → All
Hardware: PC → All
Attached patch incomplete patch (obsolete) — Splinter Review
this fixes the not calling on the second page however the width of the table on the second page is still computed wrong.
Attached patch patchSplinter Review
The patch does three things
- it places the code from bug 492661 at a much more efficient place
- it moves all table column related stuff to the first inflow, where it belongs
- it puts the flag NeedToCollapse on the first inflow too.
Assignee: nobody → bernd_mozilla
Attachment #377869 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #377933 - Flags: superreview?(roc)
Attachment #377933 - Flags: review?(roc)
Blocks: 470565
Attachment #377933 - Flags: superreview?(roc)
Attachment #377933 - Flags: superreview+
Attachment #377933 - Flags: review?(roc)
Attachment #377933 - Flags: review+
I pushed http://hg.mozilla.org/mozilla-central/rev/a5b5a8741932

the reftest fails under linux I opened bug 499578 pushed a possible fix to the try server.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
I pushed a modification to the testcase http://hg.mozilla.org/mozilla-central/rev/396f9743df7b that fixed the linux failure
You need to log in before you can comment on or make changes to this bug.