Spacebar doesn't toggle checkbox or radio buttons

VERIFIED FIXED in M10

Status

()

Core
HTML: Form Submission
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: paul, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1. Have NGLayout display a form containing a checkbox or radio button.

2. Tab to this field and press the spacebar.  You'll see a temporary change in
the widget, but not what is expected (the state being toggled).

This is the behavior using a Win32 optimized build of NGLayout, running under NT
4.0.

Updated

19 years ago
Assignee: karnaze → joki

Comment 1

19 years ago
Tom: when the tab manager is working, please reassign this bug to me.

Updated

19 years ago
Assignee: joki → karnaze

Comment 2

19 years ago
It's working well enough for this already, since these are still native
widgets.  There just isn't any visual indication of focus on the checkboxes.
You probably should have a bug for that, too.

Updated

19 years ago
Assignee: karnaze → pollmann

Updated

19 years ago
QA Contact: 4110 → 4137

Comment 3

19 years ago
Reassigning QA contact to cpratt@netscape.com (FORM QA contact).

Updated

19 years ago
Assignee: pollmann → kmcclusk

Comment 4

19 years ago
Reassigning to Kevin, since he is all over gfx checkboxes and radio buttons.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M6

Comment 5

19 years ago
*** Bug 4972 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M6 → M7

Updated

19 years ago
Target Milestone: M7 → M8

Updated

19 years ago
Target Milestone: M8 → M9

Updated

19 years ago
Assignee: kmcclusk → rods
Status: ASSIGNED → NEW
Rod, re-assigning to you.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Fixed. Joki got this working. Only tested GFX versions.

Updated

19 years ago
Whiteboard: Aug-14-99: Don't see a fix! Need GFX version

Comment 8

19 years ago
Using the 1999070614 (actually Aug-14-99) build under Windows 98, I don't see
this fixed. I'm not marking it as verified until I can get a GFX version...
(Assignee)

Comment 9

19 years ago
Please do not test or write anything about form controls bug status unless you
are testing with GFX. Thanks, this will save me a lot of time, read about bugs.

Updated

19 years ago
Status: RESOLVED → REOPENED
Whiteboard: Aug-14-99: Don't see a fix! Need GFX version

Updated

19 years ago
Resolution: FIXED → ---

Comment 10

19 years ago
Reopening as I cannot very this as fixed using the 1999082616 build under
Windows NT with GFX widgets enabled. Here is what I did to reproduce:

1 - Loaded http://schist/forms/input_checkbox.html to get a simple page with
checkboxes
2 - Clicked once into a checkbox to check it
3 - Pressed the spacebar to toggle it back to unchecked (this works well in
Communicator 4.x)

This did not work as expected. Either nothing happened or spaces were appended
to the URL in the Location: control.

Updated

19 years ago
Target Milestone: M9 → M10

Comment 11

19 years ago
Changing to M10 since M9 is already released.
(Assignee)

Comment 12

19 years ago
This is not a problem with the GFX controls, we are not receiving the correct
keyCodes from the system. It was working now it broke this maybe be depending on
bugs #6449 and/or #8379
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
Fixed for the moment until IME breaks event processing again

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 14

18 years ago
verified fixed at the url given by cpratt in m10 builds
You need to log in before you can comment on or make changes to this bug.