java applet does not get keyboard focus

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: t.hartwig, Assigned: danielle.pham)

Tracking

({regression})

1.8 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

Java applet does not get the keyboard focus, so you can't enter any text into the textields. If you try to give it a focus with a mouse click, the focus just keeps where it was.

Reproducible: Always

Steps to Reproduce:
1. Open the given URL
2. Try to enter some text in the login field

Actual Results:  
Keyboard input is not entered.

Expected Results:  
Keyboard input should be arrived in the textfield.

Java is enabled via the Sun provided java plugin libjavaplugin_oji.so: Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)

Mozilla (5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1)

with the same JDK works without prolems.
Keywords: regression

Comment 1

13 years ago
worksforme with SeaMonkey 1.0 and seamonkey trunk build 2006013001 and Java plugin 1.5.0_05-b05
Assignee: general → nobody
Component: General → Plug-ins
Product: Mozilla Application Suite → Core
QA Contact: general → plugins
Version: unspecified → 1.8 Branch

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
This should be a major Firefox bug because on Opera, Intenet Explorer and Netscape 7.1 applet that uses user key input works just fine.

Comment 3

13 years ago
I don't see the problem using 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060425 Minefield/3.0a1
+
Java(TM) 2 Platform Standard Edition 5.0 Update 6
    File name: NPJPI150_06.dll
    Java Plug-in 1.5.0_06 for Netscape Navigator (DLL Helper)

I'm able to enter text into user name and password fields.

Can anyone reproduce with recent trunk or branch builds?

jst doesn't recall hearing anything reported like this on Firefox in the last two months.

Assignee: nobody → danielle.pham

Updated

13 years ago
Flags: blocking1.9a1?
(Reporter)

Comment 4

13 years ago
Problem still exists and only in Seamonkey (tested on FC5):

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060413 Fedora/1.0.1-1.fc5 SeaMonkey/1.0.1

Even Firefox is working well with the same java plugin.

Comment 5

13 years ago
I can enter login and password on linux with Java 1.5.0_06 and firefox 1.5.0.3

But THE BUG STILL EXISTS, you can reproduce it at http://www.wiris.com/demo/appletfocus/

It is impossible to enter text in the text field on linux.... It is a big bug because the product we sell is a web formula editor (Applet) which does not work now on linux....

The things seems to be worse when there is a textarea in the same page.

(the source of the TestFocusApplet http://www.wiris.com/demo/appletfocus/src/test/TestFocusApplet.java)
(Reporter)

Comment 6

13 years ago
I'm sorry to say, I can't reproduce the behaviour now. It is really strange. After a reboot it seems to work now. All I have done is to use a Java distribution packaged by Jpackage. However the Java binary is quite the same.

Bruno, your problem seems to be a different one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.