Taskbar logo shows as Navigator wheel and not SeaMonkey logo until a 2nd window/component is opened

RESOLVED DUPLICATE of bug 321927

Status

SeaMonkey
Themes
RESOLVED DUPLICATE of bug 321927
12 years ago
10 years ago

People

(Reporter: RenegadeX, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

When SeaMonkey starts, the taskbar icon shows as the Navigator wheel, and not the SeaMonkey logo as one would expect. However, when a 2nd window is opened - either a 2nd Navigator window, or mail/news, or Chatzilla, Composer, or Address Book, the taskbar icon changes to the SeaMonkey logo.

Reproducible: Always

Steps to Reproduce:
1. Open SeaMonkey; observe the tasbar icon.
2. Click any of the SM task icons in the lower-left to open a 2nd window.
3. Note the taskbar icon now.

Comment 1

12 years ago
I see the navigator wheel consistently (classic theme) with 1.0 and current trunk
Assignee: general → nobody
Component: General → Themes
Product: Mozilla Application Suite → Core
QA Contact: general → themes
Version: unspecified → 1.8 Branch
I can typically get the logo as the icon when opening the preferences, fwiw.
(Reporter)

Comment 3

12 years ago
Hmm... a user on the news.mozilla.org SeaMonkey support newsgroup pointed out something that I hadn't considered...
[quote]
 'SeaMonkey' is not the name of just the browser, it is
 the name of the entire suite (which contains the components Navigator,
 Mail & Newsgroups, Composer, etc.).  Even though the browser is
 typically the most used component, it still wouldn't make sense for just
 one of the components to have the SeaMonkey icon while the rest have
 component-specific icons.
[/quote]

This makes sense when you consider that were you to choose any 1 component to be the only open window (ex: start SM, open 'mail/newsgroups', and then close the 'Navigator' window), the icon for that 1 component ('mail/newsgroups', in this case) would need to 'switch' to the SM logo in order to be consistent. And giving all of the components and other window-icons the same SM default-logo could be considered somewhat confusing for some users. Icons are used to visually differentiate items as an alternative/addition to its accompanying text!

Still, many users will expect to open SeaMonkey, and after enjoying the pleasant SeaMonkey-logo'd splash-screen, see the SeaMonkey logo in their Taskbar.

The 'solution' to this dilemna is, I fear, component icons based on the the main SeaMonkey logo. And due to the chosen design for the SM logo, it may be quite challenging to come up with icons that incorporate some aspect of the SM logo with an obvious indication to the component's purpose AND while remaining clear & recognizable even at a size of 16x16..

Comment 4

12 years ago
When I start SeaMonkey/open a new window I can see the SeaMonkey logo changing to the Navigator wheel (or one of the other Mozilla component icons). The Preferences window, the Select User Profile window and the various managers under the Tools menu (except the Download Manager) all show the SeaMonkey logo.

(In reply to comment #3)
> The 'solution' to this dilemna is, I fear, component icons based on the the
> main SeaMonkey logo.

Maybe something like the component icons from the Orb Colours Classic theme? See http://img379.imageshack.us/my.php?image=20060103ver016navrndurltab0qp.jpg 
(the Component Bar at the bottom).

Comment 5

12 years ago
The replacements of window/component icons (i.e. those shown in the OS's taskbar representing the windows of suite components) will be dealt with in bug 321927, duping to that one (btw, this is no theme issue, the taskbar icons are independent of themes).

*** This bug has been marked as a duplicate of 321927 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.