If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Possible memory leak with extended browsing - maybe MySpace?

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Toby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Over an extended browing session (several hours) I am getting consistent error messages combined with heavt memory usage. The error message I get is "The procedure entry point ?Alloc@nsMemory@@SAPAXI@Z could not be located in the dynamic link library xpcom.dll" along with a current memory usage of 89K and climbing. 

I can't say if there was a specific event that caused the problem. I was browsing MySpace.com when the error started popping up on almost every page view. I've only got two tabs open but I *have* been listening to streaming audio via the Flash players on MySpace URLs over the last two hours.

Just seems that opening and closing tabs over an extended period of time, paging back and forth, and utilizing various streaming technologies has caused a leak somewhere. 

Closing Firefox and reopening gets me back to square one with low memory usage.

Reproducible: Didn't try
"The procedure entry point ?Alloc@nsMemory@@SAPAXI@Z could not be located in the
dynamic link library xpcom.dll"

This error message means that there is an old dll is calling a changed interface in XPCOM a part of Firefox).
I suggest that you uninstall Firefox, clean the Firefox subdirectory maunally and reinstall Firefox and you used Plugins (Java, Flash).

This part of your bug report is invalid because this is caused by third-party software.

Memor Leak bug reports are only usefull with a testcase or exact steps to reproduce. 

Marking this bug invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.