font-family tags will not always work in anchor tags.

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Ronald Buckman, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US) Mozilla/m13
BuildID:    2000022820

In the page at http://members.truepath.com/ron text in  the colored link boxes
on the left side of the page should be in the Comic Sans MS font, if that font
is installed.  In Mozilla, it is in a serif font.  The Comic Sans MS font is
specified in the following external stylesheet.
http://members.truepath.com/ron/Np.css


Reproducible: Always
Steps to Reproduce:
1.goto http://members.truepath.com/ron/
2.
3.


Actual Results:  The text in colored link boxes on the left side of the page is
in a serif font.

Expected Results:  Displayed the text in a Comic Sans MS font.

This code in an external stylesheet.

a.bar { text-decoration: none; font-weight: 600; font-family:"Comic Sans MS",
Monaco, sans-serif }
a.bar:link { color: white } a.bar:visited { color: yellow } a.bar:active {
color: #90ee90 }
#crimson { background-color:#dc143c }

This code in a table cell of a program.

<H5>
<A CLASS=bar ID=crimson HREF="someurl.htm">&nbsp;Some Link&nbsp;</A>
</H5>

Comment 1

18 years ago
-> Style System
Assignee: cbegle → pierre
Component: Browser-General → Style System
QA Contact: asadotzler → chrisd
(Assignee)

Comment 2

18 years ago
This sure looks like a valid style bug: however it is crashing loading the page 
right now in the ContentSink.

I've created a testcase and it is fine... I'll attach that.
Assignee: pierre → attinasi
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

18 years ago
Created attachment 8353 [details]
Testcase with font specified as in reported problem

Comment 4

18 years ago
The M15 build doesn't crash and shows the page at the URL above correctly. M15 
was released shortly after the bug was filed. The reporter was using M13.
(Assignee)

Comment 5

18 years ago
Based on the testcase and Pierre's comments, marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
The links at the left in the page are comic sans MS, and so is the text in the 
testcase.  However, I don't see the anchor in comic sans MS in the testcase.  
Marc, is this a known bug? Or do you want me to file?

Code that isn't showing up at all is:
<A class=bar HREF="http://www.attinasi.org">Anchor in Comic Sans MS font</A>

Let me know, thanks

vrfy wfm 2000062408 win98 (original problem is fixed)
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

18 years ago
I'm not sure if it is a known bug - the strict doctype is causing the A not to 
show up, even if I remove the class which causes the styling. Chanign the 
doctype to transitional makes it all work fine.

I'll ask the parser owner if there is a know problem with an A in a strict 
doctype. Thanks Blake, I'll report back what Harish has to say.
(Assignee)

Comment 8

18 years ago
Created attachment 10817 [details]
Corrected testcase for strict DTD (A is now inside of a P)
(Assignee)

Comment 9

18 years ago
I updated the testcase. I believe that the strict DTD requires that an Anchor be 
inside of a block element, in this case I put it inside of a Paragraph. I'm 
still checking to make sure that there is no bug here, but I vaguely remember 
Rick G. talking about this peculiar aspect of the STRICT DTD. If anybody is 
knowledgable on this detail, please chime in...
(Assignee)

Comment 10

18 years ago
Harish verified that an <A> in a <BODY> is illegal in the strict DTD. The <A> 
must be in a block element. Note that the testcase has been updated.

Comment 11

18 years ago
Thanks, marc. So it's not a bug, then?
(Assignee)

Comment 12

18 years ago
No, it is not a bug, it is a feature! Seriously, that is the way the HTML4 
strict DTD says it has to be, strange as it seems. Thanks again, Blake.
You need to log in before you can comment on or make changes to this bug.