Adress autocomplete no longer fills in default domain

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: psfales, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050927
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050927

In Mozilla mail and thunderbird 1.0.7, when composing mail and entering an address, "@mycompany.com" is automatically appended.   (I believe this is taken from the account owners email adress, e.g. myhandle@mycompany.com)   Starting in thunderbird 1.5, this feature is no longer working.

There are a couple of possibly related bugs dealing with autocompletion, but as far as I can tell, it was never intended to disable this filling in of the default domain:

https://bugzilla.mozilla.org/show_bug.cgi?id=265509
https://bugzilla.mozilla.org/show_bug.cgi?id=244522

Was this change intentional?  If it was, can it be restored, perhaps by changing a preference setting?

Reproducible: Always

Steps to Reproduce:
1. Open compose window
2. Starting typing a name not in any address book (e.g. xyzzy)
3.

Actual Results:  
xyzzy is displayed red

Expected Results:  
xyzzy@mycompany.com  is displayed
(Reporter)

Comment 1

13 years ago
Looks like this must have been a deliberate change.   A user pointed me to the prerence setting: mail.identify.default.autocompleteToMyDomain  

Changing the default value of false to "true" restored the desired behavior
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.