background dom updates cause firefox to "flicker"

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Keith Irwin, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

I've written a javascript application which hides and reveals bits and pieces of a page sometimes in response to a completed xmlHttpRequest.  Your usual stuff.  With the default firefox on ubuntu (1.0.7), this all works fine.  With 1.5 and 1.5.0.1, I get a lot of "flicker", either the areas clear before being repainted, or invisible content appears for a split second.

Now, I might just assume I'm doing something wrong (though it worked before), but this also affects the smooth transitions in gmail.com, and, surely, those guys know what they're doing!


Reproducible: Always

Steps to Reproduce:
1. Log in / access your gmail account
2. Click between the predefined searches: Inbox, Sent Mail, Drafts
3. Pay attention to the obvious screen repaint.

Actual Results:  
You can see the screen repaint.

Expected Results:  
You don't see the screen or area repaint.

Related to #308055, I bet.

https://bugzilla.mozilla.org/show_bug.cgi?id=308055

Having to absolutely position a whole lot of variable length textual elements (or tabular) seems a bit overkill for what used to work fine.  Also, it's much nicer to be able to just redraw a table with one new line in it than to process a lot of DOM elements and insert a row into a table (if that's even possible).

On the other hand, quicker reflow and redraw is nice too!  What a dilemma!

Are you guys going to tell Google to rewrite their app? (That sounds nasty, but, really, I don't mean to be!)

Just seems like something's not quite right.  Like maybe redraw/reflow should be fast when you're download pages, maybe a bit slower when you're manipulating the dom.  Shrug!
(Reporter)

Comment 1

12 years ago
If it matters:

Same prob on:

   Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050628

Works fine on:

   Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060217 Firefox/1.6a1
Works for me; I'm getting no flicker.
(Reporter)

Comment 3

12 years ago
I can confurm that with 1.6a on Ubuntu Breezy (not that that matters). Gmail is once again a smooth experience.  However, my little ajax app is still hurky/jerky.   Part of that is no doubt due to architectural mistakes I made, but, still, I don't see the effects on older versions.
Could you attach the source code? (Try cutting it down first to make it at least somewhat efficient.)
(Reporter)

Comment 5

12 years ago
Alas, but the code is proprietary, so I can't do that.  But I can hack up an example this weekend.  I'll do that, and perhaps post it to a website as well.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
I can't reproduce using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/20070701 Minefield/3.0a6pre ID:2007070104. 

Also works for me in Firefox 2.0.0.4 on Fedora F7.

Closing as WFM.

Reporter, if you're still seeing this, please comment with details and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.