Make autoconf build work with MSVC .NET 2003 + cygwin

RESOLVED DUPLICATE of bug 301035

Status

Directory
LDAP C SDK
RESOLVED DUPLICATE of bug 301035
12 years ago
12 years ago

People

(Reporter: Rich Megginson, Assigned: mcs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
There are a number of issues with making the build work with the new free MSVC .NET 2003 + platform sdk and cygwin.
1) need to use cygpath -m on all nspr, nss, and svrcore user supplied paths
2) There is no more lib.exe - use link.exe /lib
3) Some headers have disappeared
4) general cross platform makefile fixes
5) add libutil to autoconf build
(Reporter)

Comment 1

12 years ago
Created attachment 210485 [details]
files for fix
(Reporter)

Comment 2

12 years ago
Created attachment 210486 [details]
diffs for fix
(Reporter)

Comment 3

12 years ago
see also bug 301035

1) Don't set the -lsvrcore in SVRCORE_LIBS in configure - instead, do it the
way we do the NSPR and NSS libs, in build.mk
2) For the component LINK macros, use name.lib instead of -lname on Windows
3) The new free MSVC compiler does not have lib.exe - add an autoconf test for
the lib program and use link /lib if missing
4) If using MSVC (which expects DOS style absolute paths) and cygwin (which
uses unix style abs. paths), use cygpath -m on all user supplied paths to make
sure they are in the correct format for cl and link.  It's better to do this
during configure rather than depend on cygwin_wrapper which is much, much
slower.
5) Don't link with the odbc libs (Why did we ever need these!?!??!?)
6) The free MSVC doesn't include afxwin.h, so use the other header files
instead
7) Add libutil to the Windows build, including getting rid of the old Makefile
and adding a new Makefile.in for the autoconf build (the Makefile.client
remains)
8) getopt.c doesn't need lber.h
(Reporter)

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 301035 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.