Download Manager Corrupts or Truncates Downloaded Files

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
critical
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Merton Campbell Crockett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

My system is a dual-core 2.3 GHz PowerMac G5 with 2.5 GB of memory running Mac OS X 10.4.4.  The browser is Firefox 1.5.  I have an 802.11g wireless network with a Linksys 802.11g wireless cable modem.

The problem with downloaded files being corrupted or truncated was first noticed two weeks ago when attempting to download the latest release of Apple's Xcode Tools.  The file was approximately 803 MB.  The most recent failure involved the Firefox 1.5.0.1 release a significantly smaller file.

I attempted the Xcode Tools download multiple times.  In none of the attempts did Download Manager report an error.  It behaved as if the file transfer had completed normally.  In each attempt, only 300 to 400 MB was transferred.  In each instance the transfer lasted only 15 to 20 minutes.

I switched to Safari and was able to download the file successfully albeit at a much slower transfer rate than Firefox.

Initially the download of the new Firefox release was done in the background when I opened the browser.  When I clicked on the prompt to install the software update, an installation failure was reported due to the download being incomplete.  I went to the "Get Firefox" web site.  Again, Download Manager reported that the transfer had completed prematurely.

I switched to Safari and was able to download the update without problems.

The most bothersome element of the download failures is the failure of the Download Manager to inform the user of a failure.  To all intent and purposes it appears that the transfer completed successfully.

Reproducible: Always

Steps to Reproduce:
1.  Go to the Apple Developer's web site or the Get Firefox web site
2.  Download the Xcode Tools 2.2.1 file or Firefox 1.5.0.1 file
3.  Download Manager appears to complete successfully.
4.  Click open in the Download Manager.
5.  Mount reports that the disk image is corrupt.




This seems to be similar to bugs reported for Windows regarding incomplete downloads and several that mentioned timeouts or the Download Manager "hanging".  In the Mac OS X environment, it appears that there might be a timer involved but tcpdump indicates that data is being successfully transferred until the connection is closed by the Download Manager.

Comment 1

12 years ago
(In reply to comment #0)
> My system is a dual-core 2.3 GHz PowerMac G5 <..>

Maybe Core bug 208843 isn't completely fixed?
(Reporter)

Comment 2

12 years ago
Based on the comment that this might be related to other problem reports involving systems with multiple processors, I downloaded the two Xcode Tools disk image (833.7 MB - not 803 MB as I stated previously) using a PowerBook G4 that had not yet been upgraded from Firefox 1.5 to 1.5.0.1.  While I was performing the transfer Firefox detected that a new version was available and downloaded that while I was downloading Xcode Tools.

This time the download completed successfully.  The disk image was not truncated or corrupted and mounted successfully.  After verifying the disk image was good, I clicked the prompt to restart Firefox and install the update.  This time the update was successful.

The PowerBook G4 is a single processor (1.5 GHz) system with 1 GB of memory running Mac OS X 10.4.4 and Firefox 1.5.

This test lends credence to the suggestion that there is a logic flaw in the Download Manager that results in download failures on multi-processor systems.  The absence of a lock around non-re-entrant code segment?
(Reporter)

Comment 3

12 years ago
Another test was conducted using the dual-core PowerMac G5 after installing Firefox 1.5.0.1.  This is not the Firefox 1.5.0.1 Update.  The update failed because the file was truncated when it was downloaded.  This is the complete Firefox 1.5.0.1 that was, manually, downloaded and installed.

The Xcode Tools disk image file that was truncated in each of 6 attempts to download the file using Firefox 1.5 was downloaded successfully on the first attempt using Firefox 1.5.0.1.  The problems with the Download Manager appear to have been corrected in the latest release of Firefox.

The only "bug" in the Download Manager, now, is its calculation of the time remaining.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

12 years ago
We don't know what bug/patch fixed this, works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.