ask spidermonkey to include an xref from jspubtd.h to mozilla/js/jsd/idl/jsdIDebuggerService.idl

RESOLVED INVALID

Status

Other Applications
Venkman JS Debugger
RESOLVED INVALID
13 years ago
3 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
seamonkey mozilla/js/jsd/idl/jsdIDebuggerService.idl
  126      * VERSION_* values must be kept in sync with the JSVersion enumeration in
  127      * jspubtd.h.

  131      * Possible values for jsdIScript::version and jsdIContext::version.
  132      */
  133     const long VERSION_1_0     = 100;
  134     const long VERSION_1_1     = 110;
  135     const long VERSION_1_2     = 120;
  136     const long VERSION_1_3     = 130;
  137     const long VERSION_1_4     = 140;
  138     const long VERSION_1_5     = 150;

unfortunately,
   60  * Run-time version enumeration.  See jsconfig.h for compile-time counterparts
   61  * to these values that may be selected by the JS_VERSION macro, and tested by
   62  * #if expressions.
   63  */
   64 typedef enum JSVersion {
   65     JSVERSION_1_0     = 100,
   66     JSVERSION_1_1     = 110,
   67     JSVERSION_1_2     = 120,
   68     JSVERSION_1_3     = 130,
   69     JSVERSION_1_4     = 140,
   70     JSVERSION_ECMA_3  = 148,
   71     JSVERSION_1_5     = 150,
   72     JSVERSION_1_6     = 160,
   73     JSVERSION_DEFAULT = 0,
   74     JSVERSION_UNKNOWN = -1

they aren't very well sync'd.
(Assignee)

Comment 1

13 years ago
Created attachment 210453 [details] [diff] [review]
add message to jspubtd.h
Attachment #210453 - Flags: review?(brendan)
*** Bug 325560 has been marked as a duplicate of this bug. ***
Comment on attachment 210453 [details] [diff] [review]
add message to jspubtd.h

No.  Please fix the jsd stuff to use jspubtd.h's fine enums.  Duplication is a waste of all our time, as is this bug.

/be
Attachment #210453 - Flags: review?(brendan) → review-
(Assignee)

Comment 4

12 years ago
brendan: i can't. this is an .idl file for reflecting into js. change spidermonkey to offer an idl file for this stuff and we'll gladly use it. (heck, provide some special javascript object which exposes the same info, and i'll use that.)
This is idiot's delight, make-work not just for now but forever.  Instead, write a sed script or something.

/be
(Assignee)

Updated

11 years ago
Keywords: helpwanted
(Assignee)

Updated

10 years ago
QA Contact: caillon → venkman
JSD is gone.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.