Type identification problem

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: seamonkey, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

SeaMonkey 1.0 identifies the above URL as a type:

application/octet-stream

where Mozzy 1.7.12 identifies it as

application/text

This means that Mozzy is ably to open the URL, but SeaMonkey isn't.

Problem persists after clearing the cache, so doesn't seem connected with a bad cache entry.



Reproducible: Always

Comment 1

13 years ago
http://habarixenu.livejournal.com/data/atom is served up with "Content-Type: text/xml; charset=utf-8".  Both SeaMonkey and Mozilla display it as XML.
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

13 years ago
Just tried again here. And I still have the problem. If it helps to identify excatly what SeaMonkey says on trying to open the link is:

The file "atom" is of type application/octet-steam, and SeaMonkey does not know how to handle this file type.

If I save the file to disk, its also full of garbage - like its been unecoded incorrectly.

I dug a bit deeper - trying to open the link in IE and Opera also show the link as application/octet-steam , on my machine here its only Mozzy that opens it as an XML file.

So given that it has the same effect on IE and Opera does seem to show that its not a SeaMonkey problem - but what is causing the problem is confusing to me.

 
(Reporter)

Comment 3

13 years ago
Ah - traced the problem some more. Turns out that Mozzy was using a cached version of this file. Clearing the cache in Mozzy and it has the same error.

Hence it seems a smoking gun that my proxy has got a duff file on it, and problem is nothing to do with SeaMonkey.

Hence am closing down this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.