hang at www.spectral.com/diode.htm because of java applet

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: chrisk, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I can load http://www.spectral.com/diode.htm into Safari without a problem, but Firefox freezes as soon as it starts to load it.  I can send it a "Quit" from the Dock, but eventually I have to go to the command line and run "kill".


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.spectral.com/diode.htm
2. Observe hang
3. Run kill



Expected Results:  
See http://www.spectral.com/diode.htm without a hang

Comment 1

13 years ago
Seems not to be a problem for the Windows version.

WFM. Firefox 1.5.0.1 ID:2006011112. Win XP.

Updated

13 years ago
Severity: normal → critical
Keywords: hang

Comment 2

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060130 Firefox/1.6a1

I see a 8-second hang, but then the page appears and it is no longer unresponsive. 

The page contains a Java applet.
(Reporter)

Comment 3

13 years ago
Ah. Java.  For eclipse, I just changed the version of Current:

/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK -> 1.4.2

was changed to

/System/Library/Frameworks/JavaVM.framework/Versions/CurrentJDK -> 1.5

which points to 1.5.0 on Mac OS 10.4.4.

I will undo that.
(Reporter)

Comment 4

13 years ago
Changing back to 1.4.2 allowed the original problem site to work.

Along the way to fixing this, I notice that http://www.java.com/en/dukeszone/ will now render, the applet runs, and then I can try selecting things from firefox's menu but neither that nor clicking on the window's contents ever does anything.

Not the same hang, but a different one.  With java off the rest of the page works (e.g. links).

Updated

13 years ago
Summary: This URL http://www.spectral.com/diode.htm causes Firefox to hang, requires "kill pid" to stop → hang at www.spectral.com/diode.htm because of java applet

Comment 5

13 years ago
Chris - any news here? Since this wasn't confirmed, was it possibly due to you multiple and possibly conflicting installations (did you do it manually...?)? Please update us and state latest versions & how vanilla the installations are.
(Reporter)

Comment 6

13 years ago
It works for me in the current Firefox 1.5.0.3 and with Java version 1.5.0_06 from Apple Computer

Updated

12 years ago
Blocks: 353557

Comment 7

12 years ago
Following comment #6  ===> WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
No longer blocks: 353557
You need to log in before you can comment on or make changes to this bug.