Make SSLSocket.setSSLDefaultOption public

RESOLVED DUPLICATE of bug 208193

Status

RESOLVED DUPLICATE of bug 208193
13 years ago
12 years ago

People

(Reporter: nkwan, Assigned: rrelyea)

Tracking

4.2.3
x86
Linux

Details

(Reporter)

Description

13 years ago
Can we make SSLSocket.setSSLDefaultOption a public function? 
Currently, there is no way enable or disable TLS via 
JSS's SSL interface.

Comment 1

13 years ago
This is a reasonable request. But if we were to make SSLSocket.setDefaultOption public, then 

[1] I am not sure if this needs to be static.
[2] If we use the SSL options listed in SocketBase.java, this needs to be converted from protected to public as well.

Listed below is the build error seen when accessing public setDefaultOption.

./org/mozilla/jss/tests/SSLClientAuth.java:136: org.mozilla.jss.ssl.SocketBase is not public in org.mozilla.jss.ssl; cannot be accessed from outside package
           org.mozilla.jss.ssl.SSLSocket.setSSLDefaultOption(SocketBase.SSL_BYPASS_PKCS11,true);
                                                             ^

Comment 2

12 years ago
Thomas opened this bug to have a way to enable or disable TLS via 
JSS's SSL interface. Bug 208193 implemented this feature. 
I am marking this bug as a duplicate of 208193. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 208193
You need to log in before you can comment on or make changes to this bug.