Partial Update Failed when Upgrading to 1.5.0.1

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Scott MacGregor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
My partial update failed this morning when I updated to 1.5.0.1.

The last few lines of the update log look like:

PREPARE PATCH extensions/inspector@mozilla.org/install.rdf
PREPARE PATCH extensions/inspector@mozilla.org/defaults/preferences/inspector.js
PREPARE PATCH extensions/inspector@mozilla.org/chrome/inspector.jar
PREPARE PATCH extensions/inspector@mozilla.org/components/inspector.dll
CRC check failed
LoadSourceFile failed
failed: 4
calling QuitProgressUI
There is a report on the QA blog that both the Swedish and Slovenian build failed as well for users. I will spend some time testing this. My initial test of upgrading Slovenian from 1.5->1.5.01 resulted in a PASS for Partial update.
(Reporter)

Comment 2

13 years ago
the last file in the log is from DOM inspector which is an optional install component if you do a full install I think (or is it defaulted to on?). That could be a good place to start from when trying to reproduce.
The partial update from 1.5 to 1.5.0.1 failed on three of my four systems.  It failed on a Windows 2000 SP4 and two Windows XP SP2.

     Software Update
     Update Failed
     The partial Update could not be applied.
     Firefox will try again by downloading a
     complete Update.

The complete update then succeeded.  The partial update only succeeded on a Windows Server 2003 SP1.

The Windows installs are English versions with Icelandic regional settings.  Firefox is English version.

I have a number of extensions installed on the systems that failed and I have also deleted some of the default search plugins.  I have no extensions installed on the system that succeeded and have left the search plugins intact.

There have been some speculations that a partial update will fail if some of the default search plugins are missing.  If that's the case then surely it must be fixed.  There is no need to increase the download ten-fold just so that I can delete the default search plugins yet again?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
This issue as reported in comment #0 would have been caused by the inspector.dll used to create the partial being different than the one installed on the system that was updated. We no longer ship inspector so resolving -> wfm
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.