Closed Bug 325693 Opened 14 years ago Closed 14 years ago

renaming default profile folder name causes "FF already running but not responding, close FF existing process, or restart your system" error

Categories

(Toolkit :: Startup and Profile System, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: michichi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

i had to rename (shorten) my default FF folder, because i could not clear cache folder, due to "path too long for trash folder window xp error" and forgot about it.
after this i was not able to start firefox at all - every time i tried to launch it i got this error message: "Close Firefox. Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system" did not work - Firefox safe mode, restarting  WindXP system, nor WinXp safe mode
only after i searched for all files that i or the system may have changed before this error occured, i found out - the profile renaming could be the problem. using backed up profile name, i was able to start firefox again.

note 1.: i have only one abcdefgh.default folder in my Firefox profiles folder, as i deleted the originaly created (i migrated the whole mozilla folder, cause i formatted and reinstalled xp), but i guess the same happens with more existing but not matching folders as with empty profiles folder

note 2.:i use C: for my WinXp drive, but it can be any other drive(name), where you have installed your xp


Reproducible: Always

Steps to Reproduce:
1.close Firefox

2.open C:\Documents and Settings\YourWinXpUserName\Application Data\Mozilla\Firefox\Profiles

3.rename 'abcdefgh.default' to 'a' or 'a.default' (keeping or deleting .default extension does not make a difference)

4.1.start Firefox.exe (using quick launch, desktop shortcut, or start menu) 

goto 5.-7.5.Actual Results

4.2.log out from WinxProfile and log in again. goto 4.1.

4.3.reboot Winxp. goto 4.1.
Actual Results:  
5.get error message: "Close Firefox. Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system" with "OK" button

5.5.check all available process or task manager to see - there is NO "duplicate" firefox process at all, except the actual one, that reports you the "phantom" already running process error and refuses to continue with the start up. 

6.click "OK"

7.Firefox exits.

7.5. now there is no running process of Firefox at all in process or task manager


Expected Results:  
There is no difference if there is allready at least one profile folder in C:\Documents and Settings\YourWinXpUserName\Application Data\Mozilla\Firefox\Profiles BUT with wrong (unrecognized renamed) name OR its empty.
##The same appears to happen, when Firefox cant load, because the default profile is corrupted.

8.Firefox opens Profile Manager Window with a message: "Firefox cannot start, because it is unable to locate abcdefgh.default folder. or ##Firefox cannot start because the defaultprofilename.default folder is corrupted. Should Firefox use/create another/new default folder?" with options:
"Yes, use existing profile folder as default profile folder" goto 8.1.
"Yes, create new default profile folder." goto 8.2.
"No. Exit profile manager and close Firefox." goto 10.

8.1. choice "Yes, use existing profile folder as default profile folder" opens C:\Documents and Settings\YourWinXpUserName\Application Data\Mozilla\Firefox\Profiles as 'Select as new default folder'window with options: 
"select" goto 8.1.1.
"browse" in saved(backup)profile locations, opens some folder where you have stored Firefox profiles with the same options like 8.1.
"cancel" goto 8.

8.1.1. choice "select" - Firefox seemingly takes the selected folder from C:\Documents and Settings\YourWinXpUserName\Application Data\Mozilla\Firefox\Profiles (or from another folder where you have stored Firefox profiles), autocompletes or adjusts its name if necessary (i guess 'selected/adjustedfolder-name'.default) and asks:
"Firefox will now use 'selectedfolder-name' as 'selected/adjusted-foldername.default'" with options:
"accept" goto 9.
"choose another name and accept" goto 9.
"cancel" goto 8.

##(in case this profile is corrupted - the same menu of profile manager should pop up again, using the message:"Firefox cannot start because the defaultprofilename.default folder is corrupted. Should Firefox use/create another/new default folder?" goto 8

8.2. choice "Yes, create new default profile folder." - Firefox seemingly creates completely new default profile folder and asks: "Firefox will now use 'created-foldername.default' as new default profile" with options:
"accept" goto 9.
"choose another name and accept" goto 9.
"cancel" goto 8.

9. Firefox (after users "accept" in fact, not just seemingly) adjusts the existing (8.1) or creates new (8.2.) 'defaultprofilename.default' profile folder and STARTS.

10.If you know, that the problem occurs, because you either renamed the folder and forgot to rename it back or that you deleted the folder and forgot to replace it with your backup, you can now go to C:\Documents and Settings\YourWinXpUserName\Application Data\Mozilla\Firefox\Profiles and change the name back to original (using your backup)  or replace it yourself. ;-)
In order to change 'abcdefgh.default' to 'a.default' you need also to change it in profiles.ini.
It may also be necessary to delete extensions.ini. This to make the extensions work.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.