add css style for all day events

RESOLVED FIXED in 0.9

Status

Calendar
Calendar Views
--
minor
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Torsten, Assigned: Fallen)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

All day events are shown with the start time 0:00 in the new views. Since the start time 0:00 is a redundand information it should be dropped. This would improve the clarity of the calendar view.

Reproducible: Always

Steps to Reproduce:
1. Create an all day event
2. The event is displayed with start time 0:00
3.

Actual Results:  
The all day event is displayed with start time 0:00.

Expected Results:  
The all day event is displayed without start time.
(Reporter)

Updated

12 years ago
Summary: Display of needless tart time 0:00 for all day events in new views → Display of needless start time 0:00 for all day events in new views
Version: unspecified → Trunk
I agree to that. In addition Bug 322981 will benefit from this.

If not done yet there also should be a special style rule assigned to the all day events. Thus themes could highlight all day events, e.g. with a special symbol as in Sunbird 0.2.
Assignee: base → nobody
Status: UNCONFIRMED → NEW
Component: Base → Sunbird and Calendar-Extension Front End
Ever confirmed: true
OS: Windows XP → All
QA Contact: base → sunbird
Hardware: PC → All
Summary: Display of needless start time 0:00 for all day events in new views → Do not display start time 0:00 for all day events in new views

Comment 2

12 years ago
Created attachment 211663 [details] [diff] [review]
Patch to prevent start time from showing on all day events

First patch! ;)

This patch doesn't address the second part of this bug, i.e., assigning all day events a special style.
Attachment #211663 - Flags: first-review?(jminta)

Comment 3

12 years ago
Comment on attachment 211663 [details] [diff] [review]
Patch to prevent start time from showing on all day events

Great job on your first patch.  In terms of styling for all-day events, you probably use a selector (like the selected item in the view currently does).  The other option would be to define a special css-class for those events, but I don't think that would fit in as well with the current model.  I may be wrong though. r=jminta
Attachment #211663 - Flags: first-review?(jminta) → first-review+

Comment 4

12 years ago
"Patch to prevent start time from showing on all day events" checked in.  Leaving bug open for work on styling.

Comment 5

12 years ago
Start and end time should also not be shown in tooltips. Is this a styling-thing or a new bug?

Comment 6

12 years ago
(In reply to comment #5)
> Start and end time should also not be shown in tooltips. Is this a
> styling-thing or a new bug?
> 
That's handled in bug 331145.

Comment 7

12 years ago
changed summary, because the main concern has been fixed.
Component: Sunbird Only → Calendar Views
Summary: Do not display start time 0:00 for all day events in new views → add css style for all day events

Comment 8

11 years ago
An "All Day" event on a PRINTED monthly view calendar shouldn't show the words "All Day" when the event is for All Day.  If no time is chosen, the Event should be blank on the PRINTED version just like it is on the regular visual monthly view calendar.
(In reply to comment #8)
This is already fixed with Bug 352433 for the current 0.7 release.

Comment 10

10 years ago
Fixed by bug 202360?

Updated

10 years ago
Assignee: nobody → philipp
Yes, fixed by bug 202360.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Depends on: 202360
Target Milestone: --- → 0.9
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.