cache or refresh problem with <select> <option selected> html tag

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 46845
12 years ago
12 years ago

People

(Reporter: jimace, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If a page has a selection box, with a default selection that can change from the backend. The selection box will not render correctly after a soft refresh.(default selection is not updated) It will however render correctly after a hard refresh (shift-F5)



Reproducible: Always

Steps to Reproduce:
1. create simple html:

<html>
<head>
</head>
<body>
<select name="myname">
<option value="1">1</option>
<option value="2">2</option>
<option selected value="3">3</option>
<option value="4">4</option>
</select>
</body>
</html>

2. upload this html to any server, and load it up with firefox
   you will see the option "3" as selected

3. telnet to the server and change the code to this (just changed 'selected')

<html>
<head>
</head>
<body>
<select name="myname">
<option value="1">1</option>
<option selected value="2">2</option>
<option value="3">3</option>
<option value="4">4</option>
</select>
</body>
</html>

3. Click the refresh button, and notice that value "3" is still selected.
   NOTE: if you now look at the source code, you'll see that the source code
   is correct, but the rendering is not. So it's not a cache problem i guess

4. Hit Shift-F5 and it will render correctly



I was using these selection boxes for displaying database information. Since one of the options in the selection boxes was a 'delete user' option, several of our users got deleted by accident when someone refreshed a page and clicked submit.

I checked with some colleagues, and it has been reproduced on several computers with:
FF 1.0  (no extensions or plugins)
FF 1.5  (google toolbar and webdeveloper plugin)
FF 1.5.0.1 (google toolbar and webdeveloper plugin)

Comment 1

12 years ago
Duplicate of Suite bug 282030 -> Core bug 46845?

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.