configure script use system cairo though --disable-system-cairo is set

RESOLVED INVALID

Status

Firefox Build System
General
RESOLVED INVALID
12 years ago
2 months ago

People

(Reporter: Takanori MATSUURA, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.9a1) Gecko/20060120 Fedora/1.6a1-2006011915_trunk Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.9a1) Gecko/20060120 Fedora/1.6a1-2006011915_trunk Firefox/1.6a1

I'm now testing firefox-trunk on Fedora Core 5 test 2 (FC5T2).

configure script uses system cairo though '--disable-system-cairo' is set.
Output from configure script is the following:
checking MOZ_GTK2_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking MOZ_GTK2_LIBS... -lgtk-x11-2.0 -latk-1.0 -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgmodule-2.0 -ldl -lgobject-2.0 -lglib-2.0

Reproducible: Always

Steps to Reproduce:
1. run configure script with '--disable-system-cairo'
Actual Results:  
cairo installed on the system is detected

Expected Results:  
Cairo in the trunk source should be used.
I don't think anything can be done about this. The system gtk2 uses the system cairo.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)

Hmm...
Yes. 'pkg-config [--cflags|--libs] gtk+-2.0' returns cflags and libs that includes cairo, as you say.

1. If we run configure script with '--enable-system-cairo', firefox
cannot build because firefox-trunk source calls cairo-1.1-specific
functions.
2. If we run configure script with '--disable-system-cairo', firefox
cannot build because system cairo is detected by 'pkg-config
gtk+-2.0'.
(Reporter)

Comment 3

12 years ago
Created attachment 213269 [details] [diff] [review]
patch that I can build succcessfully.

In Fedora Core 5test3, I can build firefox-trunk with this patch.

This patch is from firefox SRPM package by Fedora Core Rawhide.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not relevant for fx3.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.