Menu background colour streaks across <pre> enclosed content.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: chrisjhaig, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051111 Firefox/1.5

When going to the web page http://www.quirksmode.org/css/condcom.html and scrolling through the page, the right side 'Contents' menus background colour appears to bleed through to the content area where the page content is enclosed within the <pre> ... </pre> HTML elements, leaving streak-like lines randomly, as if it were scratching the content area.

This generally only happens if the 'content' menu moves over the far right side  of the <pre> ... </pre> enclosed content. On a larger screen res for example (above my 800 x 600) the menu doesn't move over the <pre> ... </pre> enclosed content, and so no streaks are left. Also, if the browser window is resized to be smaller horizontally, there is a point where the streak effect will again stop appearing. It's as if there is a small zone on the web page that Firefox doesn't like, and streaks it when the menu moves over it.

I'm sorry to say that I didn't really know how to brand this bug, so couldn't find a previous bug report in Bugzilla, so if this is a duplicate, I apologise.

Reproducible: Always

Steps to Reproduce:
1. Load up http://www.quirksmode.org/css/condcom.html in Firefox 1.5 (I'm using the GB build).
2. Scroll down the page to where the code example for the IE conditional comments are shown (this section is inside the <pre> ... </pre> HTML elements), making sure the 'content' menu directly moves across the content (too far right and the menu won't go over the content and hence won't cause the streak effect).
3. Scroll back up the page to view the streaks left in the same colour as the menus background.

Actual Results:  
Streaks left over the page content which is enclosed within the <pre> ... </pre> HTML elements.

Expected Results:  
No streaks to be left, and instead the page to scroll as normal,

The software should not have left the streaks over the content.
(Reporter)

Comment 1

13 years ago
Created attachment 210573 [details]
Screen shot before the <pre> content is covered by the menu.
(Reporter)

Comment 2

13 years ago
Created attachment 210574 [details]
Screen shot when the <pre> content is covered by the menu.
(Reporter)

Comment 3

13 years ago
Created attachment 210575 [details]
Screen shot after the <pre> content has been covered by the menu, causing the streak effect.
(Reporter)

Comment 4

13 years ago
Created attachment 210576 [details]
Screen shot of smaller browser window, after scrolling the page, but with no streak effect appearing.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060202 Firefox/1.6a1 ID:2006020221
I see it in 1.8 and in 1.8.0 but not in trunk.
Repaired on trunk somewhere in January 2006.
Reporter, do you still see this problem with a recent trunk Firefox build? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME
Version: unspecified → 1.5.0.x Branch
Due to the lack of activity on this bug and the fact that I cannot reproduce it using Firefox 2.0.0.6 and Minefield 2007083005, and the fact that the CSS of the testcase page has changed dramatically since the bug was filed; I am resolving this bug as WORKSFORME.  Reporter, if you still have the problem after updating to the latest version of Firefox, please reopen the bug and post any more information you can give.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME
You need to log in before you can comment on or make changes to this bug.