Last Comment Bug 325784 - Call nsINavHistory::markPageAsFollowedBookmark when following a bookmark
: Call nsINavHistory::markPageAsFollowedBookmark when following a bookmark
Status: RESOLVED DUPLICATE of bug 409301
swag: 0.5 days
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: P4 normal (vote)
: Firefox 3
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 11:22 PST by Brett Wilson
Modified: 2009-11-26 06:20 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Brett Wilson 2006-02-03 11:22:20 PST
When the user follows a bookmark by selecting it from a menu, the toolbar, or the places page, we should call nsINavHistory::markPageAsFollowedBookmark before opening the URI. This will mark the transition as a bookmark transition. Don't call this when following history links.
Comment 1 (not reading, please use seth@sspitzer.org instead) 2007-06-19 11:32:18 PDT
mass re-assign of ben's, pam's, annie's, and joe's places bugs.
Comment 2 Phil Ringnalda (:philor) 2008-01-05 13:38:59 PST

*** This bug has been marked as a duplicate of bug 409301 ***
Comment 3 Gervase Markham [:gerv] 2009-11-26 06:20:05 PST
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv

Note You need to log in before you can comment on or make changes to this bug.