View menu-button no longer appears in trunk builds

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: xolaware.llc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: version 1.6a1 (20060124)

in recent versions of thunderbird, it would appear that the real estate housing the "View:" menu-button and the mini-search bar has been reclaimed with the mini-search item moving up to the icon utility area.

(since i found these both eminently usable in their previous form, i'm sticking with build 1.6a1 20060124 and not updating any further until i know for certain i won't lose this functionality.)

Reproducible: Always

Steps to Reproduce:
1. open a regular "Mail & Newsgroups" window
2. visit the Inbox (or any other folder) of any account


Actual Results:  
View menu (with choices like "All", "Unread", labels & custom choices) is gone

Expected Results:  
View menu should still be there (even if quick-search area gets moved)

this may be a planned line of features, but i don't think i am the only one who would find it extremely disturbing if the very useful view menu-button disappears as part of a planned line of development.  perhaps if some desire not having the menu-button, it's location can be made into a pref.  (and this would go for the location of the quick-search button as well, which i find much more useful in its wide form in its pre-20060124 location beside the view menu-button as compared with its post-20060125 location next to the icons ... where it is also much narrower and hard to see all of.)

Comment 1

12 years ago
Related to bug 325310 -> bug 325030?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to bug 325310 -> bug 325030?
> 

i don't think this is actually related.  that bug (which you can see via attachment in its report) is talking about the "Messages" submenu-item in the "View" menu of the main toolbar, whereas what i'm talking about is the "View" menu-button that appears (or used to) in the headers pane of the "Mail & Newsgroups" window beside the old quick-search window.

(and i'll acknowledge that i understand that perhaps what i'm talking about is not a bug at all but perhaps a design change, in that it may be the case that the intention is to move both the quick-search box and the "view->messages" menu button into an icon form in the main icon bar of each "Mail & Newsgroups" window.  i'd just prefer to have a way to preserve the older behavior -- which, incidentally, is as it appears in 1.5.)
QA Contact: front-end

Comment 3

10 years ago
Jay do yo usee this?
Assignee: mscott → nobody
I'm not sure where I should see it. Can you spot it in Windows? I'm having Virtual Machine issues right now, so can't get Tb installed on my Windows VM to check and see what it looks like.

Comment 5

10 years ago
I thought he was refering to something mac-specific. but perhaps not.

does the following work?  right-click toolbar (just above subject,from,...), customize, drag view widget to toolbar
Oh, that is what we're talking about. I read the problem description several times, and I thought the submitter was talking about a "View" in the Left Hand Side View Pane (in default three pain |= view).

Since he's just talking about the Toolbar, yeap, View drop down menu is there. Works perfectly for me and I'm not sure I ever remember it disappearing. I can't remember a specific time when it disappeared, but I've been running Trunk as my daily work mail user for a year or so now.

It could be the submitter is running a very narrow window and the Search box on the far right wins out and crunches over top of other toolbar icons/drop downs? I'm on a different Mac laptop at the moment, and it doesn't run Tb, so can't tell. Will check tomorrow if needed.

BTW, WRT my running nightly trunks: Yeah, yeah, I know, I'm asking for trouble... but I certainly spot things faster that way... hopefully I never spot the "wipes out all of my saved messages in IMAP" bug... maybe it is time to pick the current nightly and call it stable for myself since it works perfectly for me. :)
(Reporter)

Comment 7

10 years ago
as submitter, i can acknowledge what i had speculated on at the time i submitted the bug:  there was a design change.  the view menu used to appear in the headers pane, and it is now available to appear on the toolbar.  i was not aware that this change was in the works at the time i submitted the bug.  i'm changing the status of it (i'd change it to "not-a-bug" but i don't see that as an option, so i'm changing it to "fixed").
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 8

10 years ago
Correcting resolution.
->INVALID
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.