Not all news.mozilla.org posts are on Google

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: cilias, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
This is probably an issue between Giganews and Google. Not all posts on news.mozilla.org are making it to Google. So far, it seems random.
For instance:
The "2006-01-30 - Summary of mozilla.org staff meeting" post by Gerv in mozilla.dev.planning did not make it to google, but "2006-01-16 - Summary of mozilla.org staff meeting", which was posted just two minutes earlier did make it. And a response to the post that did not make it, /was/ archived on Google.
I've forwarded this to both Giganews and Google.
Assignee: server-ops → justdave
response from Giganews:
============================
Looking through the group on our servers, I found the corresponding message ID for both articles in question:

"2006-01-30 - Summary of mozilla.org staff meeting"
<nt-dnT_bF9kA_H7eRVn-pw@mozilla.org>

"2006-01-16 - Summary of mozilla.org staff meeting"
<nt-dnTzbF9m9_H7eRVn-pw@mozilla.org>

I checked against Google's server that we feed to, it returns it has already seen those two message IDs, which means we've already passed them on to them.

200 news4.google.com InterNetNews server INN 2.4.2 (20041025 prerelease)
ready
IHAVE <nt-dnTzbF9m9_H7eRVn-pw@mozilla.org>
435 Duplicate
IHAVE <nt-dnT_bF9kA_H7eRVn-pw@mozilla.org>
435 Duplicate
quit
205 .

When I go to Google Groups and browse mozilla.dev.planning, I only see two articles: from Nitin at Feb 4, 1:05 am, and Philip at Feb 3, 12:58 pm.

When I use the 'Advanced Search' on Google Groups to do a message ID lookup, it can not find either message:

The requested message, <nt-dnTzbF9m9_H7eRVn-pw@mozilla.org>, could not be found.
The requested message, <nt-dnT_bF9kA_H7eRVn-pw@mozilla.org>, could not be found.

This tells me that we've correctly passed on the articles to Google, and for whatever reason Google is not finding/displaying them.
Anyone have any recent examples of this?  Google thinks the existing examples are too old to prove anything is amiss...
(Reporter)

Comment 4

12 years ago
I did some tests in mozilla.test on Monday.
Message:<CPCdncytO8ewTXreRVn-oQ@mozilla.org> did not show on Google.

I'll see if I can catch anything more recent, as well as do another series of tests.

Comment 5

12 years ago
Some post in mozilla.dev.builds is missing:
Date: Mon, 06 Feb 2006 08:11:36 +0800
Message-ID: <PvWdnfA3NYKuCXvenZ2dnUVZ_sKdnZ2d@mozilla.org>

and possibly in mozilla.dev.tech.layout some postings are also missing (but maybe they still show up in Google Groups since they are quite new):
Message-ID: <J9adnadNHpKCSHfenZ2dnUVZ_sqdnZ2d@mozilla.org>
Message-ID: <1_qdndF13vS6AXfenZ2dnUVZ_vudnZ2d@mozilla.org>
(Reporter)

Comment 6

12 years ago
In mozilla.dev.mozilla.org <iZadnb0EsI1UIHfeRVn-pQ@mozilla.org> was posted 4 hours ago. It's not on Google.
Thanks, I've sent these along.
Response from Google:

---8<---
I looked at it today, but have not found the reason yet.

A couple of our edge servers _sometimes_ were not propagating
articles further after getting them from Giganews, so the
articles were not indexed. I have not seen anything like
that before, and I confirmed it happens only for some
mozilla.* articles (all other hierarchies are ok). Maybe INN
is "getting confused" because of the special mozilla.*
configuration.

I restarted the servers and have not found any missing article
since from 9:51am PST today.
---8<---
(Reporter)

Comment 9

12 years ago
I guess restarting the servers hasn't completely fixed it.
Message id: <8NudnXNPgqb3HXLeRVn-sw@mozilla.org> in mozilla.support.firefox is missing.
Feb 12 10:37:31.028 - news-out.nntp.giganews.com <8NudnXNPgqb3HXLeRVn-sw@mozilla.org> 437 Article posted in the future -- "Mon, 13 Feb 2006 11:42:21 -0700"
(Reporter)

Comment 11

12 years ago
I've been trying pretty hard to find misses, and haven't. Looks fixed to me.
Marking as FIXED
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.