SVG Printing fonts too big. Displays OK.

RESOLVED DUPLICATE of bug 314707

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 314707
12 years ago
12 years ago

People

(Reporter: Nigel Maddocks, Unassigned)

Tracking

({regression})

1.8 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

SVG: 
Deer Park Alpha 2: Displays OK, Prints OK
Firefox 1.5.0.1:   Displays OK, Prints fonts much too big.

The SVG is loaded in an IFRAME within a normal frame which is within a normal frame.

Reproducible: Always

Steps to Reproduce:
SVG is:
<?xml version="1.0" standalone="yes"?>

<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11-flat-20030114.dtd " [
  <!ENTITY s7 "stroke-width:1;">
  <!ENTITY s28 "font-family:'Arial';">
  <!ENTITY s30 "font-size:8pt;">
  <!ENTITY s31 "font-weight:bold;">
  <!ENTITY s32 "fill:none;">

  <!ENTITY s33 "fill:yellow;">
  <!ENTITY s34 "fill:red;">
  <!ENTITY s35 "fill:green;">
  <!ENTITY s3c "font-size:19;">
  <!ENTITY s72 "stroke:#000000;">
  <!ENTITY s7b "fill:#FFFFFF;">
  <!ENTITY s86 "fill:#000000;">
  <!ENTITY s90 "stroke-dasharray:.125in,.0625in;">
]>

<svg xmlns="http://www.w3.org/2000/svg" version="1.0" xmlns:xlink="http://www.w3.org/1999/xlink" width="510px" height="317px">
<rect x="300" y="60" width="155" height="53" rx="5" ry="5" style="&s7b;&s72;&s7;&s33;" /> 
<polyline points="300 78 455 78" style="&s72;&s7;&s32;" /><a xlink:href="javascript:window.parent.changeTable('Activity')"> 
<text x="305" y="71" style="&s28;&s30;&s31;" >Activity</text> 
</a> 
<rect x="300" y="79" width="155" height="12" style="&s34;" /> 
<text x="305" y="89" style="&s28;&s30;" >ID</text> 
<text x="305" y="101" style="&s28;&s30;" >Description</text> 
<rect x="10" y="163" width="155" height="149" rx="5" ry="5" style="&s7b;&s72;&s7;&s33;" /> 
<polyline points="10 181 165 181" style="&s72;&s7;&s32;" /><a xlink:href="javascript:window.parent.changeTable('Employee_History')"> 
<text x="15" y="174" style="&s28;&s30;&s31;" >Employee_History</text> 
</a> 
<text x="15" y="192" style="&s28;&s30;" >ID</text> 

<text x="15" y="204" style="&s28;&s30;" >Employee_ID</text> 
<text x="15" y="216" style="&s28;&s30;" >Forename</text> 
<text x="15" y="228" style="&s28;&s30;" >Surname</text> 
<text x="15" y="240" style="&s28;&s30;" >Role</text> 
<text x="15" y="252" style="&s28;&s30;" >Salary</text> 
<rect x="10" y="254" width="155" height="12" style="&s35;" /> 
<text x="15" y="264" style="&s28;&s30;" >Activity</text> 
<text x="15" y="276" style="&s28;&s30;" >LastChanged</text> 
<text x="15" y="288" style="&s28;&s30;" >Operation</text> 

<text x="15" y="300" style="&s28;&s30;" >OperationDate</text> 
<rect x="185" y="163" width="155" height="113" rx="5" ry="5" style="&s7b;&s72;&s7;&s33;" /> 
<polyline points="185 181 340 181" style="&s72;&s7;&s32;" /><a xlink:href="javascript:window.parent.changeTable('Employee')"> 
<text x="190" y="174" style="&s28;&s30;&s31;" >Employee</text> 
</a> 
<text x="190" y="192" style="&s28;&s30;" >ID</text> 
<text x="190" y="204" style="&s28;&s30;" >Forename</text> 
<text x="190" y="216" style="&s28;&s30;" >Surname</text> 
<text x="190" y="228" style="&s28;&s30;" >Role</text> 
<text x="190" y="240" style="&s28;&s30;" >Salary</text> 

<rect x="185" y="242" width="155" height="12" style="&s35;" /> 
<text x="190" y="252" style="&s28;&s30;" >Activity</text> 
<text x="190" y="264" style="&s28;&s30;" >LastChanged</text> 
<polyline points="10 260 0 260" style="&s72;&s7;&s32;" /><polyline points="0 260 0 129" style="&s72;&s7;&s32;" /><polyline points="0 129 471 129" style="&s72;&s7;&s32;" /><polyline points="471 129 471 85" style="&s72;&s7;&s32;" /><polyline points="471 85 455 85" style="&s72;&s7;&s32;" /><polyline points="185 248 175 248" style="&s72;&s7;&s32;" /><polyline points="175 248 175 146" style="&s72;&s7;&s32;" /><polyline points="175 146 488 146" style="&s72;&s7;&s32;" /><polyline points="488 146 488 85" style="&s72;&s7;&s32;" /><polyline points="488 85 455 85" style="&s72;&s7;&s32;" />
</svg>


Actual Results:  
Lines printed OK (but thicker than with Deer Park Alpha 2).
Boxes printed OK.
Text printed far too bit, like about 8x too big. Overflow boxes.
But just viewed in browser, it is fine.
(Reporter)

Comment 1

12 years ago
Version: I was complaining about version 1.5.0.1 on XP SP2.
Actual Results: should read "Text printed far too big" rather than "Text printed far too bit"

This can be reproduced outside the web application. Simply save the svg code as a file suffixed .svg   . Open the file in Firefox 1.5.0.1. Look at the rendering. It's nice. Print it. It's horrible.

Open it in Deer Park Alpha 2. Look at the rendering: Nice. Print it: Just as nice.

Comment 2

12 years ago
What is the build id of "Deer Park Alpha 2"? Is it a recently-fixed-on-trunk or rather regressed-in-1.5 kind of thing?
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
(Reporter)

Comment 3

12 years ago
"Deer Park Alpha 2" was a version of Firefox between 1.0 and 1.5.  I believe the internal name for Firefox 1.5 was "Deer Park" during the development. And this was Alpha release 2.  Just a Firefox download that was generally available.  I wouldn't know how to compile anything.

The "About" menu item in the browser (which I'm using at this moment) says "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+". I can't see anything that gives a build ID.

Still the main point is that SVG doesn't print properly in the current version of Firefox.  The fact that it did print OK in an earlier version is interesting but not crucial.

Comment 4

12 years ago
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712
Okay thanks. I asked because all the trunk nightlies since then were (and still are!) labeled 'Deer Park Alpha 2'.


*** This bug has been marked as a duplicate of 314707 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Keywords: regression
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.