Last Comment Bug 325901 - Some files are preprocessed unnecessarily
: Some files are preprocessed unnecessarily
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Firefox 17
Assigned To: Andres Hernandez [:andreshm]
:
:
Mentors:
: 778621 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 10:42 PST by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2013-02-13 11:33 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
CSS files (checked in) (14.71 KB, patch)
2006-02-04 10:56 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
mconnor: review+
mconnor: approval‑branch‑1.8.1+
Details | Diff | Splinter Review
fix files in browser/base (31.31 KB, patch)
2012-07-19 16:22 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
Patch v1 browser/base (33.05 KB, patch)
2012-08-13 10:22 PDT, Andres Hernandez [:andreshm]
gavin.sharp: review+
Details | Diff | Splinter Review
Patch v1 browser/components (56.41 KB, patch)
2012-08-13 10:22 PDT, Andres Hernandez [:andreshm]
gavin.sharp: review+
Details | Diff | Splinter Review
Patch v1 browser/locales (9.27 KB, patch)
2012-08-13 10:23 PDT, Andres Hernandez [:andreshm]
gavin.sharp: review+
Details | Diff | Splinter Review
Patch v1 browser/themes (7.15 KB, patch)
2012-08-13 10:24 PDT, Andres Hernandez [:andreshm]
gavin.sharp: review+
Details | Diff | Splinter Review
rolled up browser/ patch (105.06 KB, patch)
2012-08-14 09:20 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
gavin.sharp: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2006-02-04 10:42:41 PST
This increases build time and should be fixed. I'll do CSS files first, since they're blocking the branch patch for bug 305767.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-02-04 10:56:52 PST
Created attachment 210706 [details] [diff] [review]
CSS files (checked in)
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-14 12:45:25 PST
Comment on attachment 210706 [details] [diff] [review]
CSS files (checked in)

checked in, branch and trunk. leaving open for other possible files.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-19 16:22:44 PDT
Created attachment 644063 [details] [diff] [review]
fix files in browser/base

I did a quick pass and tried to fix the files in browser/base. I haven't looked over this carefully, it may have bugs.
Comment 4 Andres Hernandez [:andreshm] 2012-08-10 09:52:40 PDT
I'll continue with this.
Comment 5 Andres Hernandez [:andreshm] 2012-08-10 13:10:18 PDT
Question, the %if 0 or #if 0 directives are required for some reason or can be removed?
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-11 22:10:00 PDT
It depends on the specific use. But I don't think you should worry about those to start - let's just get the ones that the preprocessor warns about to begin with.
Comment 7 Andres Hernandez [:andreshm] 2012-08-13 10:22:10 PDT
Created attachment 651450 [details] [diff] [review]
Patch v1 browser/base

browser/base fixes.
Comment 8 Andres Hernandez [:andreshm] 2012-08-13 10:22:56 PDT
Created attachment 651451 [details] [diff] [review]
Patch v1 browser/components

browser/components fixes.
Comment 9 Andres Hernandez [:andreshm] 2012-08-13 10:23:33 PDT
Created attachment 651452 [details] [diff] [review]
Patch v1 browser/locales

browser/locales fixes.
Comment 10 Andres Hernandez [:andreshm] 2012-08-13 10:24:09 PDT
Created attachment 651453 [details] [diff] [review]
Patch v1 browser/themes

browser/themes fixes.
Comment 11 Andres Hernandez [:andreshm] 2012-08-13 10:24:55 PDT
I'll continue with toolkit files
Comment 12 Andres Hernandez [:andreshm] 2012-08-13 14:49:47 PDT
Toolkit files are fine. Any other I should check?
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-13 15:01:49 PDT
We want to fix all the warnings that show up during a mozilla-central firefox build, but I imagine there may be a long tail. Don't need to tackle that in this bug, might be good to file a followup.
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-14 09:20:55 PDT
Created attachment 651795 [details] [diff] [review]
rolled up browser/ patch

Thanks for fixing this, Andres!
Comment 15 Andres Hernandez [:andreshm] 2012-08-14 13:22:15 PDT
Thank you, do we need a try run for this?
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-14 21:30:10 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6d0ce062c403
Comment 17 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-15 09:04:18 PDT
Nope! :)
Comment 18 Ed Morley [:emorley] 2012-08-15 09:48:03 PDT
https://hg.mozilla.org/mozilla-central/rev/6d0ce062c403
Comment 19 Matt Brubeck (:mbrubeck) 2013-02-13 11:33:07 PST
*** Bug 778621 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.