Status

Marketing
Trademark Permissions
--
trivial
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Caleb Cushing, Assigned: shaver)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.8) Gecko/20060130 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.8) Gecko/20060130 Firefox/1.5

I think I speak for the ENTIRE Gentoo Community in saying we would like to enable official branding for Firefox. This 'bug' is being filed as a place for Gentoo user's who agree with me to sign this Petition. 

Caleb Cushing

Reproducible: Always

Steps to Reproduce:
x-ref: http://bugs.gentoo.org/show_bug.cgi?id=113971 in particular comments #1 and #20.
Assignee: nobody → cbeard
Component: General → General
Product: Firefox → Marketing
QA Contact: general → gerv
(Reporter)

Comment 2

12 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Trademark Permissions
Resolving INVALID. Bugzilla is not the place for petitions and such like.

If the maintainer of the ebuild wishes to file such a request, they are welcome to do so.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

12 years ago
Anarchy "the Maintainer" said report it upstream. So I reported upstream. As I understand you are doing a good job of ignoring his bugs. as if it matter's. do you have a better 'Idea' of where I'm going to put this to get attention? I'll tell anarchy to make the request however, or he can sign this one and reopen it.
See bug 282307 for a good example of such a request.
(Reporter)

Comment 6

12 years ago
so If I had made this a more articulate request, to be signed by the gentoo community for the "trademark" you would consider it and ask what we are changing?
It is a matter for the maintainer[s], not the users.
(Reporter)

Comment 8

12 years ago
Indeed? and what is a program without user's? How many user's does firefox have right now? and where would mozilla be without a user base? well hopefully I can convince our maintainer.

Comment 9

12 years ago
With all due respect, is it not the case that the user is the one person who in the end chooses the exact components of the software he wants to use? If that is the case, then there seems to be no sufficient reason not to allow the choice of official branding to a user through the emerge mechanism in Gentoo (by defining a default-disabled USE flag with the name of "official-branding"). I entirely agree that a default branding officially will not be wise, for the aforementioned reasons of stability of source builds compared with official Mozilla releases. My argument is only that the experienced user will know how to enable official branding in any case, by using a portage overlay and using a ./configure --enable-official-branding option in the ebuild overlay.

Thus, the reason for this bug is relevant to both the experienced and unexperienced user. The Open Source initiative has always been about choice, and I sincerely hope that that prerogative of the user has not in any way been changed.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Assignee: cbeard → shaver
Status: REOPENED → NEW
(Reporter)

Comment 10

12 years ago
according to a post on the gentoo forum's, someone and if you want a name I can look it up, says anarchy 'the maintainer' told them, on IRC that we'll be getting official branding. I can link the thread if someone want's it. I however will believe it when I see it. especially when that was ~2 days ago and he said tomorrow and it hasn't come yet. But anarchy has been known to take a few more days than what he said he would get things done in.
First, this bug was marked INVALID because it was being used a petition mechanism, rather than a place in which to discuss the specifics of the request.  That is exactly the right thing to do when the bug system is abused this way, and I will not hesitate to do it again if there is more tangential advocacy or other non-constructive discussion here.  If you want to post to the world about your opinions on what should be done here, and you are not someone who is able to effect change in what gentoo ships as a default configuration, then you should sign up for a LiveJournal account or something.  Not here.

Gentoo's case is hard, because of the way it is distributed to users and the sorts of configuration flips that are present.  The Linux distributors are often a hard case, and Gentoo is one of the harder of set.  This process has also been elongated and made more difficult by miscommunications between Jory (the Gentoo package maintainer), which I believe were resolved this week.  (I don't see him cc:'d on this bug.)

Specifically: if the default configuration meets the guidelines in our distributors' trademark policy for build fidelity, then the default configuration can include --enable-official-branding.  If a user changes a configuration option that causes it to violate those guidelines, then default branding should be disabled.

Users are certainly free to build their own browsers from our source with official branding, but the test of "confusion in the marketplace" requires that the barrier to promoting or distributing a Firefox derivative with material differences _and_ the Firefox labelling be set quite high.  This is to protect both the interests of the project and the interests of the user (trademarks are, in many ways, tools of consumer protection law), and we take both of those sets of interests very seriously.
Status: NEW → ASSIGNED
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
My apologies for labeling it a petition. Perhaps I could have used a better choice of word's. I am not trying to abuse bugzilla. I do think the issue needed to be moved on though, I would have worded it differently if I could officially represent gentoo, and I had hoped that the gentoo community would make more of a response do to the large number of question's/complaint's about the issue. Many say I took the wrong approach, however no one has said what I should have done to get the ball rolling. I actually made an inquiry about a month before doing this on Pratt's thread and did not receive a response as to the approach. 

Jory Pratt (anarchy) Has not yet replied on his Firefox thread, I believe he is indifferent to the issue, or maybe he just doesn't like me. 

If the Gentoo maintainer is not representing the needs of his constituents -- and I am not saying that it's the case; I have no opinion or insight on the matter -- then that's an issue to be solved within the context of Gentoo's project mechanisms.  "Escalating" to us as a means of going "around" him is inappropriate, and will not help your cause in the long term, if indeed it even helps in the short.
(Reporter)

Comment 14

12 years ago
(In reply to comment #13)
To quote Jory "I suggest you go read the complete license and re-read it until you understand what it says. I never said it was illegal I said we do not haver permission as a distro to enable official branding. Upstream has made this clear to myself aloung with other developers. If you are offended by us not branding firefox or thunderbird 1.5 then I suggest you complain to actual upstream developers and the mozilla foundation. Also you say it does not compile but give nothing for me to even see what is breaking for ya :/"
http://forums.gentoo.org/viewtopic-p-3011491-highlight-.html#3011491

So I complained upstream. (note: I wasn't part of that conversation, I am sure I remember him saying something else, elsewhere but i haven't found it yet.

Comment 15

12 years ago
As Shaver has pointed out I was in contact with him later this week after much lapse in time between last discussion. As I pointed out to Mike the default for gentoo is to enable svg and canvas by default now which replicate the binary provided by the foundation. As I am working well over 80 hours a week I am a bit back log'd with getting things done at time frame I would like to. Does this mean it is not gonna happen, no it does not, just means it is gonna take time. If at any time upstream says we do not meet there requirements then and only then will I drop branding once again but as far as *I* can see everything is in order.
Indeed, we're in the right place here now as far as our side is concerned, so FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.