Unexpected Crash (Java refcounting bugs?)

VERIFIED WORKSFORME

Status

Camino Graveyard
General
VERIFIED WORKSFORME
12 years ago
12 years ago

People

(Reporter: ronald.gold, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Whiteboard: [CLOSEME - 4/2])

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060203 Camino/1.0rc1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060203 Camino/1.0rc1

Camino 1.0rc1 unexpectedly crashed while downloading data from http://animal.discovery.com/cams/pandavidr.html

No problems with downloading webcam data from this site in the past with previous editions of Camino (both 1.0b1 and G4 Optimized build of 1.0b1).

Reproducible: Sometimes




Crash Report will be attached.
(Reporter)

Comment 1

12 years ago
Created attachment 210765 [details]
Crash Report
Ronald, that page loads fine for me. Can you repeat the crash?

That said, the video didn't load at all.

(Note for others, RealPlayer is required to view the video.)
(Reporter)

Comment 3

12 years ago
The page loaded normally. And I also got the Real Player notice, even though I have Real Player installed. The crash happened as the site began to download the video. Subsequently when I tried to access the videocam (of panda cub at National Zoo), I got pop-up message that the link was out-dated or down, but no crashes occurred. I was able to access other videocam at this site without any difficulty.
(Assignee)

Comment 4

12 years ago
if you look at the stack, it's from a system notification about a disk change, which caused some prefs to change. It doesn't appear to have anything to do with the page or movie in question.

Any ideas what's triggering a pref change when a drive is mounted/unmounted?

Comment 5

12 years ago
Maybe this is one of those bugs caused by Java (random Obj-C extre release or soemthing)?
(Reporter)

Comment 6

12 years ago
Created attachment 212314 [details]
Crash Report

Comment 7

12 years ago
Both crashes look like refcounting bugs related to Java.
Summary: Upexpected Crash → Unexpected Crash (Java refcounting bugs?)
(Reporter)

Comment 8

12 years ago
Created attachment 212338 [details]
Crash Log
The Java connection is very tenuous -- all I see is that the JVM was started
(because a Java applet was loaded) at some point before both of these crashes
happened.

On a possibly related note, I've noticed lots of crashes in Camino (1.0b2 and
later) in methods of the NSUserDefaults class, all in OS X 10.4.4.  Once I'm
able to discern a pattern, I'll open a bug here.  (I haven't yet tried 10.4.5
-- I'm holding off while I investigate the NSUserDefaults crashes.)

Comment 10

12 years ago
ronald: can you turn off Java, and see if you still crash? Also, if you can get a repeatable caes that crashes, that would be very interesting to us.
(Reporter)

Comment 11

12 years ago
The most unexpectod feature of all of these "Unexpected Crashes" is that they are not repeatable. For example,I have searched five times on the Bug List without causing a crash. Java on or off doesn't seem to make a difference. I will let you know if and when anything repeats.
(Reporter)

Comment 12

12 years ago
Created attachment 212477 [details]
Crash log
I still see JVM stuff in that last crash log.  Have you really disabled Java?
The JVM keeps running even after Java has been disabled -- though (unless
something is wrong) neither it nor the Java Embedding Plugin ever do anything
more than sit and wait for events that will never happen.

However, there's a (small) possibility that the JVM did something while it's
running that triggers a crash a _long_ time later, even after Java has been
disabled.

To be absolutely sure a given crash has nothing to do with Java, you need to
disable Java and restart the browser.
> However, there's a (small) possibility that the JVM did something while it's
> running that triggers a crash a _long_ time later, even after Java has been
> disabled.

I should rephrase this to make it clearer:

However, there's a (small) possibility that the JVM did something while it was
enabled that triggers a crash a _long_ time later, even after it was disabled.

It's possible (though unlikely) that the crashes reported here are related to
ones that I reported at bug 326195.

I just released a new version (0.9.5+d) of the Java Embedding Plugin that
fixes the crashes I reported at bug 326195 (which seem to be caused by Apple
bugs, and which I found a way to work around).

http://javaplugin.sourceforge.net/

Reporter:  Please try my new JEP version, and let us know if it makes any
difference to the problem you reported here (i.e. the crashes).

To use the new JEP version you will need to:

1) Install it in /Library/Internet Plug-Ins/ (according to the instructions in
   the JEP Readme).
2) Remove the old JEP files (JavaEmbeddingPlugin.bundle and MRJPlugin.plugin)
   from the Contents/MacOS/plugins/ directory of your Mozilla.org browser(s).

(Reporter)

Comment 17

12 years ago
(In reply to comment #16)
> It's possible (though unlikely) that the crashes reported here are related to
> ones that I reported at bug 326195.
> 
> I just released a new version (0.9.5+d) of the Java Embedding Plugin that
> fixes the crashes I reported at bug 326195 (which seem to be caused by Apple
> bugs, and which I found a way to work around).
> 
> http://javaplugin.sourceforge.net/
> 
> Reporter:  Please try my new JEP version, and let us know if it makes any
> difference to the problem you reported here (i.e. the crashes).
> 
> To use the new JEP version you will need to:
> 
> 1) Install it in /Library/Internet Plug-Ins/ (according to the instructions in
>    the JEP Readme).
> 2) Remove the old JEP files (JavaEmbeddingPlugin.bundle and MRJPlugin.plugin)
>    from the Contents/MacOS/plugins/ directory of your Mozilla.org browser(s).
> 

Holiday caused delay in following above instructions. Have done both 1 and 2 above. Will report if crashes recur. 
Ronald, has this been OK since you upgraded the JEP version?
(Reporter)

Comment 19

12 years ago
(In reply to comment #18)
> Ronald, has this been OK since you upgraded the JEP version?
> 

Since upgrading JEP on !7 March, I have not had any crashes. Does this help pinpoint source of problem?
I'm tempted to say that in the latest JEP, Steven fixed whatever was causing these odd crashes, and that we can close this bug WFM.  

I'm not sure how frequently you were experiencing these particular crashes in the past, so why don't we wait until the end of the week to be sure.
Whiteboard: [CLOSEME - 4/2]
Closing WFM per discussion in the last few comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
QA Contact: general
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.